summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Dewar2018-04-12 14:41:36 +0100
committerAlex Dewar2018-04-12 14:41:36 +0100
commit5de3e5ef09041f49f4abf7dfc6ab1b826ac7437b (patch)
tree80ff12c3bf6e2bffa6290fd488166ee677682a18
downloadaur-5de3e5ef09041f49f4abf7dfc6ab1b826ac7437b.tar.gz
initial commit: v1.81a
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
-rw-r--r--disable-logging.patch12
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56ea596fa957
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = geneconv
+ pkgdesc = Statistical Tests for Detecting Gene Conversion
+ pkgver = 1.81a
+ pkgrel = 1
+ url = https://www.math.wustl.edu/~sawyer/geneconv
+ arch = i686
+ arch = x86_64
+ source = geneconv-1.81a.tar.gz::https://www.math.wustl.edu/~sawyer/geneconv/unix.source.tar.gz
+ source = geneconv-examples-1.81a.tar.gz::https://www.math.wustl.edu/~sawyer/geneconv/unix.examples.tar.gz
+ source = https://www.math.wustl.edu/~sawyer/geneconv/gconvdoc.pdf
+ source = disable-logging.patch
+ sha256sums = 9423bad39fc729ac8150d0630c82ca3452d30ba0f5da862a76a7358c06d0831c
+ sha256sums = 58e26a065c4ddf055cad403a30c2482db500e19de6ff6a2116b2d91aaee6b7a1
+ sha256sums = 14f91fe7437e115241cad83b1c0587791998498d085e58b8699186edb6735cd2
+ sha256sums = d61c5ef686cd47a8f2bb6e894535ce78cb47b2b7c2a53c4a3d6ec1c6a153a068
+
+pkgname = geneconv
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e2c97c02853a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+geneconv-*
+gconvdoc.pdf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a741d3c855de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Alex Dewar <alex.dewar@gmx.co.uk>
+pkgname=geneconv
+pkgver=1.81a
+pkgrel=1
+pkgdesc="Statistical Tests for Detecting Gene Conversion"
+arch=("i686" "x86_64")
+url="https://www.math.wustl.edu/~sawyer/geneconv"
+source=("$pkgname-$pkgver.tar.gz::$url/unix.source.tar.gz"
+ "$pkgname-examples-$pkgver.tar.gz::$url/unix.examples.tar.gz"
+ "$url/gconvdoc.pdf"
+ "disable-logging.patch")
+sha256sums=("9423bad39fc729ac8150d0630c82ca3452d30ba0f5da862a76a7358c06d0831c"
+ "58e26a065c4ddf055cad403a30c2482db500e19de6ff6a2116b2d91aaee6b7a1"
+ "14f91fe7437e115241cad83b1c0587791998498d085e58b8699186edb6735cd2"
+ "d61c5ef686cd47a8f2bb6e894535ce78cb47b2b7c2a53c4a3d6ec1c6a153a068")
+
+prepare() {
+ cd "$srcdir"/unix.source
+ patch -p0 -i ../disable-logging.patch
+ sed -i 's/getline/getline2/g' geneconv_helper.c
+ sed -i 's/-O3/$CFLAGS/' makgconv.csh
+}
+
+build() {
+ cd "$srcdir"/unix.source
+ sh makgconv.csh
+}
+
+package() {
+ install -Dm 644 gconvdoc.pdf "$pkgdir"/usr/share/doc/$pkgname/documentation.pdf
+
+ cd "$srcdir"/unix.source
+ mkdir -p "$pkgdir"/usr/bin
+ install -m 755 geneconv geneconv_helper "$pkgdir"/usr/bin/
+
+ mkdir -p "$pkgdir"/usr/share/$pkgname/examples
+ cp "$srcdir"/unix.examples/* "$pkgdir"/usr/share/$pkgname/examples
+ chmod +x "$pkgdir"/usr/share/$pkgname/examples/dosamps.csh
+}
diff --git a/disable-logging.patch b/disable-logging.patch
new file mode 100644
index 000000000000..f086a292437e
--- /dev/null
+++ b/disable-logging.patch
@@ -0,0 +1,12 @@
+--- vsetopts.c.old 2018-04-12 14:26:15.347943111 +0100
++++ vsetopts.c 2018-04-12 14:26:29.149006677 +0100
+@@ -133,7 +133,8 @@
+
+ /* Verbose variables */
+
+-int gscale, circular, allowindelstrat, havelog=TRUE;
++int gscale, circular, allowindelstrat;
++int havelog=FALSE;
+ int showunal, havlabels=TRUE, use_iubnucls, phylip;
+ int nomacfork, no_nexus_dcomm;
+ int dumpfrags, dumptab, dumpdif, dumpjseqs, dumpplot;