summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrobiot2021-10-30 16:08:44 +0300
committerrobiot2021-10-30 16:08:44 +0300
commitefdfead24b17a14087b7dca1b2c7d1f2f72cc996 (patch)
tree3100c2565c5b9e105ee4e5d9df0bcab5572ba7b3
downloadaur-efdfead24b17a14087b7dca1b2c7d1f2f72cc996.tar.gz
Init
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
-rw-r--r--git.sh9
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fe66059a88e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = zash
+ pkgdesc = A blazing fast gui autoclicker for linux
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/robiot/zash
+ arch = x86_64
+ arch = aarch64
+ license = GPL-3.0
+ makedepends = cargo
+ source = git+https://github.com/robiot/zash.git
+ sha512sums = SKIP
+
+pkgname = zash
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af6dc34fce2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=zash
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='A blazing fast gui autoclicker for linux'
+arch=('x86_64' 'aarch64')
+url='https://github.com/robiot/zash'
+license=('GPL-3.0')
+makedepends=('cargo')
+sha512sums=('SKIP')
+source=("git+https://github.com/robiot/$pkgname.git")
+
+build() {
+ cd $pkgname
+
+ cargo build --release
+}
+
+package() {
+ cd $pkgname
+
+ install -Dm 755 target/release/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+}
+
diff --git a/git.sh b/git.sh
new file mode 100644
index 000000000000..5d0d784f5823
--- /dev/null
+++ b/git.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+rm -r pkg src zash zash-*
+makepkg --printsrcinfo > .SRCINFO
+git add .
+
+echo "Write commit comment!"
+read input
+
+git commit -m "$input"