summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-03 18:48:02 +0800
committerChocobo12017-08-03 18:59:28 +0800
commit3ec73bd3341d3738e1957699e9faee6409868e1e (patch)
tree1d05698d002057f1a3f4a7c940ba55f5fb41e71b
downloadaur-3ec73bd3341d3738e1957699e9faee6409868e1e.tar.gz
newpkg: gengetopt-git 2.22.6.r0.g9d70a9b-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b93c89806f57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gengetopt-git
+ pkgdesc = A tool to write command line option parsing code for C programs
+ pkgver = 2.22.6.r0.g9d70a9b
+ pkgrel = 1
+ url = https://www.gnu.org/software/gengetopt/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = glibc
+ provides = gengetopt
+ conflicts = gengetopt
+ options = !makeflags
+ source = git+https://git.savannah.gnu.org/git/gengetopt.git
+ sha256sums = SKIP
+
+pkgname = gengetopt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15546a17bccb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=gengetopt-git
+pkgver=2.22.6.r0.g9d70a9b
+pkgrel=1
+pkgdesc="A tool to write command line option parsing code for C programs"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/gengetopt/"
+license=('GPL3')
+depends=('glibc')
+makedepends=('git')
+provides=('gengetopt')
+conflicts=('gengetopt')
+options=('!makeflags')
+source=("git+https://git.savannah.gnu.org/git/gengetopt.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "gengetopt"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/[-_]/./g;s/^rel.//'
+}
+
+build() {
+ cd "gengetopt"
+
+ autoreconf -i
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "gengetopt"
+
+ make check
+}
+
+package() {
+ cd "gengetopt"
+
+ make DESTDIR="$pkgdir" install
+}