summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSylvain Chiron2024-10-22 00:24:35 +0200
committerSylvain Chiron2024-10-22 00:24:35 +0200
commit1d92de86733cb00878ab8892c60afdc2e4b79e32 (patch)
treed5980defd9c2deca831f4a08325ee8fce9aacd72
downloadaur-1d92de86733cb00878ab8892c60afdc2e4b79e32.tar.gz
Publishing GenGraph v6.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0ac1da92f93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gengraph
+ pkgdesc = Graph Generator coded in C: graph classes, graph algorithms and output formats
+ pkgver = v6.1
+ pkgrel = 1
+ url = https://gitub.u-bordeaux.fr/cygavoil/gengraph
+ arch = x86_64
+ arch = pentium4
+ arch = i686
+ arch = armv7h
+ arch = aarch64
+ license = custom:CeCILL-C
+ optdepends = less: pager for help within the terminal
+ optdepends = graphviz: visualization of graphs
+ source = https://gitub.u-bordeaux.fr/cygavoil/gengraph/-/archive/v6.1/gengraph-v6.1.tar.gz
+ sha256sums = 421e6674c8c9efaef428d10d50188b0cdb68925b91dbee1a503f095d56fafc77
+
+pkgname = gengraph
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06d3752dae0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Build file for the (Arch Linux) Pacman package manager
+# Maintainer: Sylvain Chiron <chironsylvain@orange.fr>
+
+pkgname=gengraph
+pkgver=v6.1
+pkgrel=1
+pkgdesc='Graph Generator coded in C: graph classes, graph algorithms and output formats'
+arch=('x86_64' 'pentium4' 'i686' 'armv7h' 'aarch64')
+url="https://gitub.u-bordeaux.fr/cygavoil/${pkgname}"
+license=('custom:CeCILL-C')
+
+optdepends=(
+ 'less: pager for help within the terminal'
+ 'graphviz: visualization of graphs'
+)
+
+source=("${url}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('421e6674c8c9efaef428d10d50188b0cdb68925b91dbee1a503f095d56fafc77')
+
+build() {
+ make -C "${pkgname}-${pkgver}" -j9
+}
+package() {
+ yes | make -C "${pkgname}-${pkgver}" install DESTDIR="${pkgdir}" prefix=/usr
+}