summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOng Yong Xin2021-11-05 21:01:34 +0800
committerOng Yong Xin2021-11-05 21:01:34 +0800
commit46ed5ab151de70275fa6f12db9bc78e82152f4b9 (patch)
tree52d1779d779c06e60733188a4cdcb7c059e33428
parent070ef4c86308ba087f269c7b31b7e96b87a53b6b (diff)
downloadaur-46ed5ab151de70275fa6f12db9bc78e82152f4b9.tar.gz
reset
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore21
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD89
4 files changed, 70 insertions, 82 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26eb7fdafe45..a76fe45b3c00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = genie-systemd-git
- pkgdesc = A quick way into a systemd "bottle" for WSL (development version)
- pkgver = 1.27.r5.gfd49285
+ pkgdesc = A quick way into a systemd "bottle" for WSL
+ pkgver = 1.44.r6.g52800cf
pkgrel = 1
url = https://github.com/arkane-systems/genie
arch = x86_64
- license = custom:The Unlicense
- makedepends = dotnet-sdk>=3.1
+ license = Unlicense
+ makedepends = dotnet-sdk>=5.0
depends = daemonize
- depends = dotnet-runtime>=3.1
- depends = dotnet-host>=3.1
- depends = inetutils
+ depends = dotnet-runtime>=5.0
+ depends = dotnet-host>=5.0
provides = genie-systemd
conflicts = genie-systemd
+ options = !strip
+ backup = etc/genie.ini
source = git+https://github.com/arkane-systems/genie.git
- source = LICENSE
sha256sums = SKIP
- sha256sums = 88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd
pkgname = genie-systemd-git
-
diff --git a/.gitignore b/.gitignore
index 41c4d4538729..45dc8753b30c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,18 +1,3 @@
-#Force add
-
-#ignore
-### ArchLinuxPackages ###
-*.tar
-*.tar.*
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-genie/
-pkg/
-src/
+genie/*
+pkg/*
+src/*
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index cf1ab25da034..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,24 +0,0 @@
-This is free and unencumbered software released into the public domain.
-
-Anyone is free to copy, modify, publish, use, compile, sell, or
-distribute this software, either in source code form or as a compiled
-binary, for any purpose, commercial or non-commercial, and by any
-means.
-
-In jurisdictions that recognize copyright laws, the author or authors
-of this software dedicate any and all copyright interest in the
-software to the public domain. We make this dedication for the benefit
-of the public at large and to the detriment of our heirs and
-successors. We intend this dedication to be an overt act of
-relinquishment in perpetuity of all present and future rights to this
-software under copyright law.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
-IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
-OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
-ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
-OTHER DEALINGS IN THE SOFTWARE.
-
-For more information, please refer to <http://unlicense.org>
diff --git a/PKGBUILD b/PKGBUILD
index cf22f766ed90..ec875e5b4a3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,74 @@
-# Maintainer: Arley Henostroza <arllk10[at]gmail[dot]com>
-
+# Maintainer: Ong Yong Xin <ongyongxin2020+github AT gmail DOT com>
+# Maintainer: Xuanrui Qi <me@xuanruiqi.com>
+# Contributor: Rayfalling <Rayfalling@outlook.com>
+# Contributor: facekapow, rayfalling, Ducksoft
pkgname=genie-systemd-git
-_pkgname=genie
-pkgver=1.27.r5.gfd49285
+pkgver=1.44.r6.g52800cf
pkgrel=1
-pkgdesc="A quick way into a systemd \"bottle\" for WSL (development version)"
+pkgdesc="A quick way into a systemd \"bottle\" for WSL"
arch=('x86_64')
url="https://github.com/arkane-systems/genie"
-license=('custom:The Unlicense')
-depends=('daemonize' 'dotnet-runtime>=3.1' 'dotnet-host>=3.1' 'inetutils')
-makedepends=('dotnet-sdk>=3.1')
-conflicts=('genie-systemd')
+license=('Unlicense')
+depends=('daemonize' 'dotnet-runtime>=5.0' 'dotnet-host>=5.0')
+makedepends=('dotnet-sdk>=5.0')
provides=('genie-systemd')
-source=('git+https://github.com/arkane-systems/genie.git'
- 'LICENSE')
-sha256sums=('SKIP'
- '88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd')
+conflicts=('genie-systemd')
+options=(!strip)
+source=("git+https://github.com/arkane-systems/genie.git")
+sha256sums=('SKIP')
+backup=('etc/genie.ini')
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "${srcdir}/$_pkgname"
+ cd genie
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
}
build() {
- export DOTNET_CLI_TELEMETRY_OPTOUT=1
- export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
- cd "$srcdir/$_pkgname/$_pkgname"
- export DESTDIR=$pkgdir
- ls -alh
- make build
+ cd genie/binsrc
+ make -C genie
+ make -C runinwsl
}
package() {
- cd "$srcdir/$_pkgname/$_pkgname"
- make install
- install -Dm 644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd genie
+
+ # Binaries
+ install -Dm4755 binsrc/genie/bin/Release/net5.0/linux-x64/publish/genie -t ${pkgdir}/usr/libexec/genie
+ install -Dm0755 binsrc/runinwsl/bin/Release/net5.0/linux-x64/publish/runinwsl -t ${pkgdir}/usr/libexec/genie
+
+ # Environment generator.
+ install -Dm0755 othersrc/scripts/80-genie-envar.sh -t ${pkgdir}/usr/libexec/genie
+
+ # Runtime dir mapping
+ install -Dm0755 othersrc/scripts/map-user-runtime-dir.sh -t ${pkgdir}/usr/libexec/genie
+ install -Dm0755 othersrc/scripts/unmap-user-runtime-dir.sh -t ${pkgdir}/usr/libexec/genie
+
+ # Configuration file.
+ install -Dm0644 othersrc/etc/genie.ini -t ${pkgdir}/etc
+
+ # genie symlink
mkdir -p ${pkgdir}/usr/bin
- chmod +x ${pkgdir}/usr/libexec/genie
- ln -s /usr/libexec/genie/main/genie ${pkgdir}/usr/bin/genie
+ ln -s /usr/libexec/genie/genie ${pkgdir}/usr/bin/genie
+
+ # 10-genie-envar.sh symlinks
+ mkdir -p ${pkgdir}/usr/lib/systemd/user-environment-generators
+ mkdir -p ${pkgdir}/usr/lib/systemd/system-environment-generators
+ ln -s /usr/libexec/genie/80-genie-envar.sh ${pkgdir}/usr/lib/systemd/user-environment-generators/80-genie-envar.sh
+ ln -s /usr/libexec/genie/80-genie-envar.sh ${pkgdir}/usr/lib/systemd/system-environment-generators/80-genie-envar.sh
+
+ # Unit files.
+ install -Dm0644 othersrc/lib-systemd-system/wslg-xwayland.service -t ${pkgdir}/usr/lib/systemd/system
+ install -Dm0644 othersrc/lib-systemd-system/wslg-xwayland.socket -t ${pkgdir}/usr/lib/systemd/system
+ mkdir -p ${pkgdir}/usr/lib/systemd/system/sockets.target.wants
+ ln -s /usr/lib/systemd/system/wslg-xwayland.socket ${pkgdir}/usr/lib/systemd/system/sockets.target.wants/wslg-xwayland.socket
+
+ install -Dm0644 othersrc/lib-systemd-system/user-runtime-dir@.service.d/override.conf -t ${pkgdir}/usr/lib/systemd/system/user-runtime-dir@.service.d
+
+ # binfmt.d
+ install -Dm0644 othersrc/usr-lib/binfmt.d/WSLInterop.conf -t ${pkgdir}/usr/lib/binfmt.d
+
+ # man page
+ install -Dm0644 othersrc/docs/genie.8 -t ${pkgdir}/usr/share/man/man8
}
+
+# vim:set ts=2 sw=2 et: