summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArley2019-09-07 17:19:55 -0500
committerArley2019-09-07 17:19:55 -0500
commit646bdb41df290af730485c93eed62385c28b215f (patch)
tree5f6f1ce111f9a485de4cca677efcee89ef75b7e8
downloadaur-646bdb41df290af730485c93eed62385c28b215f.tar.gz
init commit
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD47
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c448b67c6997
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = genie-systemd-git
+ pkgdesc = A quick way into a systemd "bottle" for WSL (development version)
+ pkgver = 1.10.r0.g4dbb9f4
+ pkgrel = 1
+ url = https://github.com/arkane-systems/genie
+ arch = x86_64
+ license = custom:The Unlicense
+ makedepends = dotnet-sdk
+ depends = daemonize
+ depends = dotnet-runtime
+ depends = dotnet-host
+ depends = hostess
+ provides = genie-systemd
+ conflicts = genie-systemd
+ source = git+https://github.com/arkane-systems/genie.git
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = 88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd
+
+pkgname = genie-systemd-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..cf1ab25da034
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ad2c7c6e089
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Arley Henostroza <arllk[at]gmail[dot]com>
+
+pkgname=genie-systemd-git
+_pkgname=genie
+pkgver=1.10.r0.g4dbb9f4
+pkgrel=1
+pkgdesc="A quick way into a systemd \"bottle\" for WSL (development version)"
+arch=('x86_64')
+url="https://github.com/arkane-systems/genie"
+license=('custom:The Unlicense')
+depends=('daemonize' 'dotnet-runtime' 'dotnet-host' 'hostess')
+makedepends=('dotnet-sdk')
+conflicts=('genie-systemd')
+provides=('genie-systemd')
+source=('git+https://github.com/arkane-systems/genie.git'
+ 'LICENSE')
+sha256sums=('SKIP'
+ '88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/$_pkgname"
+ #Remove Debian package build
+ #patch -Np1 -i "${srcdir}/build_for_arch.patch"
+}
+
+build() {
+ cd "$srcdir/$_pkgname/$_pkgname"
+ dotnet publish -r linux-x64 --self-contained false
+ #TODO: test./build
+}
+
+package() {
+ cd "$srcdir/$_pkgname/$_pkgname"
+ install -Dm 4755 -o root "$srcdir/$_pkgname/$_pkgname/bin/Debug/netcoreapp2.2/linux-x64/publish/genie" -t "$pkgdir/usr/bin"
+ install -Dm 644 -o root "$srcdir/$_pkgname/$_pkgname/bin/Debug/netcoreapp2.2/linux-x64/publish/genie.dll" -t "$pkgdir/usr/bin"
+ install -Dm 644 -o root "$srcdir/$_pkgname/$_pkgname/bin/Debug/netcoreapp2.2/linux-x64/publish/Linux.ProcessManager.dll" -t "$pkgdir/usr/bin"
+ install -Dm 644 -o root "$srcdir/$_pkgname/$_pkgname/bin/Debug/netcoreapp2.2/linux-x64/publish/Linux.ProcessManager.dll" -t "$pkgdir/usr/bin"
+ install -Dm 644 -o root "$srcdir/$_pkgname/$_pkgname/bin/Debug/netcoreapp2.2/linux-x64/publish/System.CommandLine.dll" -t "$pkgdir/usr/bin"
+ install -Dm 644 -o root "$srcdir/$_pkgname/$_pkgname/bin/Debug/netcoreapp2.2/linux-x64/publish/Tmds.LibC.dll" -t "$pkgdir/usr/bin"
+ install -Dm 644 -o root "$srcdir/$_pkgname/$_pkgname/bin/Debug/netcoreapp2.2/linux-x64/publish/genie.runtimeconfig.json" -t "$pkgdir/usr/bin"
+ install -Dm 644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}