summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOng Yong Xin2022-03-04 12:37:19 +0800
committerOng Yong Xin2022-03-04 12:37:19 +0800
commit876b1acbffbb64a7864788c6601f82d7d3e70f88 (patch)
tree3d89ed986e04a82a93f9c2e3185370e21bc65ee3
parent0ac22a804ded5ece636425b4238a6f741ccc3d2d (diff)
downloadaur-876b1acbffbb64a7864788c6601f82d7d3e70f88.tar.gz
new build process for genie (now python-based)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD59
2 files changed, 21 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1edb8418d03..b0fd1fc24818 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = genie-systemd-git
pkgdesc = A quick way into a systemd "bottle" for WSL
- pkgver = 1.44.r30.g529d8a8
+ pkgver = 2.1.r13.g391a645
pkgrel = 1
url = https://github.com/arkane-systems/genie
arch = x86_64
license = Unlicense
- makedepends = dotnet-sdk-5.0-bin
makedepends = git
+ makedepends = python-pip
depends = daemonize
- depends = dotnet-runtime-5.0-bin
- depends = dotnet-host
+ depends = python
+ depends = python-psutil
+ depends = systemd
provides = genie-systemd
conflicts = genie-systemd
options = !strip
backup = etc/genie.ini
- source = git+https://github.com/arkane-systems/genie.git
+ source = git+https://github.com/arkane-systems/genie.git#branch=dev-2.2
sha256sums = SKIP
pkgname = genie-systemd-git
diff --git a/PKGBUILD b/PKGBUILD
index 7a5cf70be135..5047b8217131 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Ong Yong Xin <ongyongxin2020+github AT gmail DOT com>
-# Maintainer: Xuanrui Qi <me@xuanruiqi.com>
+# Contributor: Xuanrui Qi <me@xuanruiqi.com>
# Contributor: Rayfalling <Rayfalling@outlook.com>
# Contributor: facekapow, rayfalling, Ducksoft
pkgname=genie-systemd-git
-pkgver=1.44.r30.g529d8a8
+pkgver=2.1.r13.g391a645
pkgrel=1
pkgdesc="A quick way into a systemd \"bottle\" for WSL"
arch=('x86_64')
url="https://github.com/arkane-systems/genie"
license=('Unlicense')
-depends=('daemonize' 'dotnet-runtime-5.0-bin' 'dotnet-host')
-makedepends=('dotnet-sdk-5.0-bin' 'git')
+depends=('daemonize' 'python' 'python-psutil' 'systemd')
+makedepends=('git' 'python-pip')
provides=('genie-systemd')
conflicts=('genie-systemd')
options=(!strip)
-source=("git+https://github.com/arkane-systems/genie.git")
+source=("git+https://github.com/arkane-systems/genie.git#branch=dev-2.2")
sha256sums=('SKIP')
backup=('etc/genie.ini')
@@ -24,52 +24,23 @@ pkgver() {
}
build() {
- cd genie/binsrc
- # disable telemetry
- DOTNET_CLI_TELEMETRY_OPTOUT=1 make -C genie
- DOTNET_CLI_TELEMETRY_OPTOUT=1 make -C runinwsl
+ cd genie
+ make build-binaries
}
package() {
cd genie
-
- # Binaries
- install -Dm4755 binsrc/genie/bin/Release/net5.0/linux-x64/publish/genie -t ${pkgdir}/usr/libexec/genie
- install -Dm0755 binsrc/runinwsl/bin/Release/net5.0/linux-x64/publish/runinwsl -t ${pkgdir}/usr/libexec/genie
-
- # Environment generator.
- install -Dm0755 othersrc/scripts/80-genie-envar.sh -t ${pkgdir}/usr/libexec/genie
-
- # Runtime dir mapping
- install -Dm0755 othersrc/scripts/map-user-runtime-dir.sh -t ${pkgdir}/usr/libexec/genie
- install -Dm0755 othersrc/scripts/unmap-user-runtime-dir.sh -t ${pkgdir}/usr/libexec/genie
-
- # Configuration file.
- install -Dm0644 othersrc/etc/genie.ini -t ${pkgdir}/etc
-
- # genie symlink
- mkdir -p ${pkgdir}/usr/bin
- ln -s /usr/libexec/genie/genie ${pkgdir}/usr/bin/genie
+ make DESTDIR=${pkgdir} internal-package
- # 10-genie-envar.sh symlinks
- mkdir -p ${pkgdir}/usr/lib/systemd/user-environment-generators
+ # Need to fix symlinks and mandoc here because makefile generates a tar, which we don't need.
mkdir -p ${pkgdir}/usr/lib/systemd/system-environment-generators
- ln -s /usr/libexec/genie/80-genie-envar.sh ${pkgdir}/usr/lib/systemd/user-environment-generators/80-genie-envar.sh
- ln -s /usr/libexec/genie/80-genie-envar.sh ${pkgdir}/usr/lib/systemd/system-environment-generators/80-genie-envar.sh
-
- # Unit files.
- install -Dm0644 othersrc/lib-systemd-system/wslg-xwayland.service -t ${pkgdir}/usr/lib/systemd/system
- install -Dm0644 othersrc/lib-systemd-system/wslg-xwayland.socket -t ${pkgdir}/usr/lib/systemd/system
- mkdir -p ${pkgdir}/usr/lib/systemd/system/sockets.target.wants
- ln -s /usr/lib/systemd/system/wslg-xwayland.socket ${pkgdir}/usr/lib/systemd/system/sockets.target.wants/wslg-xwayland.socket
-
- install -Dm0644 othersrc/lib-systemd-system/user-runtime-dir@.service.d/override.conf -t ${pkgdir}/usr/lib/systemd/system/user-runtime-dir@.service.d
-
- # binfmt.d
- install -Dm0644 othersrc/usr-lib/binfmt.d/WSLInterop.conf -t ${pkgdir}/usr/lib/binfmt.d
+ mkdir -p ${pkgdir}/usr/lib/systemd/user-environment-generators
+ ln -s ${pkgdir}/usr/lib/genie/80-genie-envar.sh ${pkgdir}/usr/lib/systemd/system-environment-generators/80-genie-envar.sh
+ ln -s ${pkgdir}/usr/lib/genie/80-genie-envar.sh ${pkgdir}/usr/lib/systemd/user-environment-generators/80-genie-envar.sh
- # man page
- install -Dm0644 othersrc/docs/genie.8 -t ${pkgdir}/usr/share/man/man8
+ cp "othersrc/docs/genie.8" /tmp/genie.8
+ gzip -f9 "/tmp/genie.8"
+ install -Dm 0644 -o root "/tmp/genie.8.gz" -t "${pkgdir}/usr/share/man/man8"
}
# vim:set ts=2 sw=2 et: