summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfearlessdots2022-10-16 18:03:30 -0300
committerfearlessdots2022-10-16 18:03:30 -0300
commit2cbc64a74c1073b526f6e6bce577a754fbcacdbe (patch)
treea79ea62f8beb55107c21f94345c55cb0523de650
parent8fa0150ce562dece7a56901ff20a56a6bd301b7f (diff)
downloadaur-2cbc64a74c1073b526f6e6bce577a754fbcacdbe.tar.gz
Update to v16
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD73
2 files changed, 20 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ca888da100f..373cf136f286 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = genimage
pkgdesc = tool to generate multiple filesystem and flash images from a tree
- pkgver = 14
- pkgrel = 2
+ pkgver = 16
+ pkgrel = 1
url = https://github.com/pengutronix/genimage
arch = x86_64
license = GPL2
@@ -10,15 +10,11 @@ pkgbase = genimage
optdepends = genext2fs
optdepends = qemu-headless: qemu-img
optdepends = qemu: qemu-img
- optdepends = dtc
optdepends = uboot-tools: mkimage
optdepends = rauc
optdepends = android-simg2img: simg2img
optdepends = simg-tools: simg2img
- source = genimage-14.tar.gz::https://github.com/pengutronix/genimage/archive/v14.tar.gz
- source = index.html::https://github.com/pengutronix/genimage/blob/v14/README.rst
- sha1sums = 043fed792abe0280b830c61765fd44870f1fdf61
- sha1sums = SKIP
+ source = genimage-16.tar.gz::https://github.com/pengutronix/genimage/archive/v16.tar.gz
+ sha256sums = 5b5ff31e58afdcf71bd7b61f7d81ee43c4c0751276bc03d51f40475e1c66e51a
pkgname = genimage
-
diff --git a/PKGBUILD b/PKGBUILD
index bf2c4e84ef3c..8733bb558fc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,76 +1,35 @@
-# Maintainer: "Darren Ng <$(base64 --decode <<<VW4xR2ZuQGdtYWlsLmNvbQo=)>"
+# Maintainer: Filipe Bertelli <filipebertelli@tutanota.com>
+# Contributor: "Darren Ng <$(base64 --decode <<<VW4xR2ZuQGdtYWlsLmNvbQo=)>"
+
pkgname=genimage
-pkgver=14
-pkgrel=2
+pkgver=16
+pkgrel=1
pkgdesc="tool to generate multiple filesystem and flash images from a tree"
arch=($CARCH)
url=https://github.com/pengutronix/$pkgname
license=(GPL2)
-
depends=(confuse)
-
-# For "make check"
optdepends=(
-
- # function dep {
- # sudo pacman -Syu --needed "$1" \
- # || yay --gpg "$(realpath ~/beaglebone/gpg_proxy.sh)" -Syu --needed "$1"
- # sudo pacman -D --asdeps "$1"
- # }
-
- # SKIP cramfs (missing mkcramfs)
- 'cramfs-tools: mkcramfs'
-
- # SKIP ext2 (missing genext2fs of genext2fs,e2fsck)
- # SKIP ext2percent (missing genext2fs of genext2fs,e2fsck)
- # SKIP ext3 (missing genext2fs of genext2fs,e2fsck)
- # SKIP ext4 (missing genext2fs of genext2fs,e2fsck)
- genext2fs
-
- # SKIP qemu (missing qemu-img of dd,diff,qemu-img)
- 'qemu-headless: qemu-img' # qemu provides qemu-headless
- 'qemu: qemu-img' # qemu provides qemu-headless
-
- # SKIP fit (missing dtc,mkimage of mkimage,dtc)
- dtc
- 'uboot-tools: mkimage'
-
- # SKIP rauc (missing rauc)
- rauc
-
- # SKIP android-sparse (missing simg2img)
- 'android-simg2img: simg2img'
- 'simg-tools: simg2img'
-
+ 'cramfs-tools: mkcramfs'
+ 'genext2fs'
+ 'qemu-headless: qemu-img'
+ 'qemu: qemu-img'
+ 'uboot-tools: mkimage'
+ 'rauc'
+ 'android-simg2img: simg2img'
+ 'simg-tools: simg2img'
)
-# makedepends=(${optdepends[@]})
-
-# https://sphinx-rtd-theme.readthedocs.io/en/stable/
-# makedepends=(python-sphinx python-sphinx_rtd_theme)
-source=($pkgname-$pkgver.tar.gz::https://github.com/pengutronix/$pkgname/archive/v$pkgver.tar.gz
- index.html::https://github.com/pengutronix/genimage/blob/v14/README.rst)
-sha1sums=(043fed792abe0280b830c61765fd44870f1fdf61 SKIP)
+source=($pkgname-$pkgver.tar.gz::https://github.com/pengutronix/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('5b5ff31e58afdcf71bd7b61f7d81ee43c4c0751276bc03d51f40475e1c66e51a')
build() {
-
cd $pkgname-$pkgver
- # cp configure.ac{,\~}
- # autoupdate # Corrupts ./configure
- # diff -u configure.ac{\~,}
./autogen.sh
./configure --prefix=/usr --enable-silent-rules --disable-dependency-tracking
make
-
- # https://www.sphinx-doc.org/en/master/man/sphinx-quickstart.html
- # sphinx-quickstart --sep -p genimage -a "Michael Olbrich" -v 14 -r 14 -l en -d master_doc=README --ext-autodoc --ext-viewcode --ext-githubpages --no-batchfile .
- # https://www.sphinx-doc.org/en/master/man/sphinx-build.html
- # sphinx-build -b dirhtml -d .doctrees -n -v . ./build
-
}
-# https://github.com/pengutronix/genimage/issues/157
-# https://github.com/pengutronix/genimage/pull/155
check() {
cd $pkgname-$pkgver
make -k check || /bin/true
@@ -79,5 +38,5 @@ check() {
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir/" install
- install -vdm755 "$pkgdir/usr/share/doc/$pkgname"; cp -Lv "$srcdir/index.html" "$_"
+ install -vdm755 "$pkgdir/usr/share/doc/$pkgname"
}