summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Ng2021-08-04 18:48:49 +0800
committerDarren Ng2021-08-04 18:49:18 +0800
commite417dfd0c73f311b15f38c3bd15882c615b3f5cc (patch)
tree01c1d51ea95db052d90b0e55152c8123c7d1d558
parentd7c13885f94cf7a6c4e606e9d367bb977587d805 (diff)
downloadaur-e417dfd0c73f311b15f38c3bd15882c615b3f5cc.tar.gz
goodbye GitHub proprietary HTML
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
2 files changed, 6 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18bec05041ee..7ab1764581e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = genimage-git
pkgdesc = tool to generate multiple filesystem and flash images from a tree
pkgver = v14.r82.43fccb5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pengutronix/genimage
arch = x86_64
license = GPL2
@@ -18,8 +18,6 @@ pkgbase = genimage-git
optdepends = android-simg2img: simg2img
optdepends = simg-tools: simg2img
source = genimage::git+https://github.com/pengutronix/genimage.git
- source = index.html::https://github.com/pengutronix/genimage/blob/master/README.rst
- sha1sums = SKIP
sha1sums = SKIP
pkgname = genimage-git
diff --git a/PKGBUILD b/PKGBUILD
index b16983b7e51d..34c07e70085c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: "Darren Ng <$(base64 --decode <<<VW4xR2ZuQGdtYWlsLmNvbQo=)>"
pkgname=genimage-git
pkgver=v14.r82.43fccb5
-pkgrel=1
+pkgrel=2
pkgdesc="tool to generate multiple filesystem and flash images from a tree"
arch=($CARCH)
url=https://github.com/pengutronix/${pkgname%-*}
@@ -22,15 +22,8 @@ optdepends=(
'simg-tools: simg2img'
)
-# makedepends=(${optdepends[@]})
-
-# https://sphinx-rtd-theme.readthedocs.io/en/stable/
-# makedepends=(python-sphinx python-sphinx_rtd_theme)
-source=(
- ${pkgname%-*}::git+https://github.com/pengutronix/${pkgname%-*}.git
- index.html::https://github.com/pengutronix/${pkgname%-*}/blob/master/README.rst
-)
-sha1sums=(SKIP SKIP)
+source=(${pkgname%-*}::git+https://github.com/pengutronix/${pkgname%-*}.git)
+sha1sums=(SKIP)
pkgver() {
cd ${pkgname%-*}
@@ -39,12 +32,6 @@ pkgver() {
build() {
cd ${pkgname%-*}
-
- # echo
- # pwd
- # echo
- # return 1
-
# autoupdate # Corrupts ./configure
./autogen.sh
./configure \
@@ -62,5 +49,6 @@ check() {
package() {
cd ${pkgname%-*}
make DESTDIR="$pkgdir/" install
- install -vdm755 "$pkgdir/usr/share/doc/${pkgname%-*}"; cp -Lv "$srcdir/index.html" "$_"
+ install -vdm755 "$pkgdir/usr/share/doc/${pkgname%-*}"
+ cp -Lv README.rst "$_"
}