summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhejiang2021-12-07 15:16:20 +0800
committerhejiang2021-12-07 15:16:20 +0800
commitc828de9262c22b44df3bb288c6f9354cd5d9c53e (patch)
tree6167032329937a85b0e3d4963f18ad394eb4c2b1
parentfa403b7100e752e58192fba93f28e0d1fd46d1d8 (diff)
downloadaur-c828de9262c22b44df3bb288c6f9354cd5d9c53e.tar.gz
update pkgbuild
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD43
2 files changed, 25 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4d7fae99e32..710da69b2349 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = genmake
pkgdesc = generate C/C++/Go Makefile template
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitee.com/duapple/genmake/attach_files/904692/download/genmake
arch = x86_64
license = AGPL-3.0
makedepends = git
- noextract = genmake
- noextract = genmake_conf.json
- source = genmake::https://gitee.com/duapple/genmake/attach_files/904692/download/genmake
- source = genmake_conf.json::https://gitee.com/duapple/genmake/attach_files/904564/download/genmake_conf.json
- md5sums = SKIP
+ source = /template::git+https://gitee.com/duapple/makefile.git
+ source = https://gitee.com/duapple/genmake/attach_files/904692/download/genmake
+ source = https://gitee.com/duapple/genmake/attach_files/904564/download/genmake_conf.json
md5sums = SKIP
+ md5sums = cb3845ee35a1bea7b44daa7a9fef3aaf
+ md5sums = 2bb569a143fa683893369eba49e8652c
pkgname = genmake
diff --git a/PKGBUILD b/PKGBUILD
index e6bd35f0cb8e..54214db1b8f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,34 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
# Maintainer: duapple <2832893880@qq.com>
+
pkgname=genmake
pkgver=0.4.0
-pkgrel=1
-epoch=
+pkgrel=2
pkgdesc="generate C/C++/Go Makefile template"
-arch=(x86_64)
+arch=('x86_64')
url="https://gitee.com/duapple/genmake/attach_files/904692/download/genmake"
license=('AGPL-3.0')
depends=()
makedepends=("git")
-checkdepends=()
optdepends=()
-source=("${pkgname}::${url}"
- "genmake_conf.json::https://gitee.com/duapple/genmake/attach_files/904564/download/genmake_conf.json")
-noextract=("${source[@]##*/}")
-md5sums=("SKIP"
- "SKIP")
+source=("${srcdir}/template::git+https://gitee.com/duapple/makefile.git"
+ "${url}"
+ "https://gitee.com/duapple/genmake/attach_files/904564/download/genmake_conf.json")
+noextract=()
+md5sums=("SKIP" "cb3845ee35a1bea7b44daa7a9fef3aaf" "2bb569a143fa683893369eba49e8652c")
prepare() {
- rm -rf ${srcdir}/template
- git clone https://gitee.com/duapple/makefile ${srcdir}/template
- rm -rf ${srcdir}/template/.git
-}
+ rm -rf ${pkgname}-${pkgver}
+ mkdir -p ${pkgname}-${pkgver}
+ mv template ${pkgname}-${pkgver}
+ mv genmake ${pkgname}-${pkgver}
+ mv genmake_conf.json ${pkgname}-${pkgver}
+}
package() {
- mkdir -p ${pkgdir}/usr/bin/
- cp ${srcdir}/${pkgname} ${pkgdir}/usr/bin/
- chmod 777 ${pkgdir}/usr/bin/${pkgname}
mkdir -p ${pkgdir}/usr/share/${pkgname}/
- cp -r ${srcdir}/template ${pkgdir}/usr/share/${pkgname}/template
mkdir -p ${pkgdir}/usr/share/${pkgname}/config
- cp ${srcdir}/genmake_conf.json ${pkgdir}/usr/share/${pkgname}/config/
-}
+ cd ${pkgname}-${pkgver}
+ install -Dm777 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ mv template ${pkgdir}/usr/share/${pkgname}/template
+ cp genmake_conf.json ${pkgdir}/usr/share/${pkgname}/config/
+} \ No newline at end of file