summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-12-13 12:07:50 -0600
committerLuis Martinez2021-12-13 12:07:50 -0600
commitc6eb918308e34a52e2637601f68cb195fbcf6f5b (patch)
tree098af7447898a377233e85b905a6dd0d515972c3
downloadaur-c6eb918308e34a52e2637601f68cb195fbcf6f5b.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad98ac2e331a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = genmake-templates-git
+ pkgdesc = Makefile templates for genmake
+ pkgver = r2.0f13b05
+ pkgrel = 1
+ url = https://gitee.com/duapple/makefile
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = genmake
+ provides = genmake-templates
+ conflicts = genmake-templates
+ source = genmake-templates-git::git+https://gitee.com/duapple/makefile
+ sha256sums = SKIP
+
+pkgname = genmake-templates-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd66639111a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=genmake-templates-git
+pkgver=r2.0f13b05
+pkgrel=1
+pkgdesc="Makefile templates for genmake"
+arch=('any')
+url="https://gitee.com/duapple/makefile"
+license=('unknown')
+depends=('genmake')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm644 *.conf -t "$pkgdir/usr/share/genmake/templates/"
+}