summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Chaplin Braz2020-09-23 20:53:02 +0200
committerAlexander Chaplin Braz2020-09-23 20:53:02 +0200
commit1dc170bea433c4bd33614b137c7e160ea05803fe (patch)
tree3b1acc5ae04f3e2a52c055297097918eee333c0b
downloadaur-1dc170bea433c4bd33614b137c7e160ea05803fe.tar.gz
Release 1.0.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD20
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8037815fee7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = genrepass-bin
+ pkgdesc = Generate a readable password from an ordered list of words extracted from text
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/AlexChaplinBraz/genrepass
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = gcc-libs
+ depends = libxcb
+ depends = glibc
+ depends = libxau
+ depends = libxau
+ conflicts = genrepass
+ conflicts = genrepass-git
+ source_x86_64 = https://github.com/AlexChaplinBraz/genrepass/releases/download/1.0.0/genrepass-x86_64-unknown-linux-gnu-1.0.0.tar.gz
+ sha256sums_x86_64 = 1125da3258f7e1b91e200c2ea03b6b6e3f6e2358ce4e9dbc313fa2fe9de6b457
+ source_i686 = https://github.com/AlexChaplinBraz/genrepass/releases/download/1.0.0/genrepass-i686-unknown-linux-gnu-1.0.0.tar.gz
+ sha256sums_i686 = 9061fe21bbc6b90107fc327cc6098930b34c99c2e9832e62546808ced08d4490
+
+pkgname = genrepass-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0588ed55c516
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Alexander Chaplin Braz <contact@alexchaplinbraz.com>
+pkgname='genrepass-bin'
+_pkgname='genrepass'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Generate a readable password from an ordered list of words extracted from text'
+arch=('x86_64' 'i686')
+url='https://github.com/AlexChaplinBraz/genrepass'
+license=('MIT')
+depends=('gcc-libs' 'libxcb' 'glibc' 'libxau' 'libxau')
+conflicts=('genrepass' 'genrepass-git')
+source_x86_64=("$url/releases/download/$pkgver/genrepass-x86_64-unknown-linux-gnu-$pkgver.tar.gz")
+source_i686=("$url/releases/download/$pkgver/genrepass-i686-unknown-linux-gnu-$pkgver.tar.gz")
+sha256sums_x86_64=('1125da3258f7e1b91e200c2ea03b6b6e3f6e2358ce4e9dbc313fa2fe9de6b457')
+sha256sums_i686=('9061fe21bbc6b90107fc327cc6098930b34c99c2e9832e62546808ced08d4490')
+
+package() {
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}