summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexChaplinBraz2022-10-03 20:14:53 +0000
committerAlexChaplinBraz2022-10-03 20:14:53 +0000
commitf1d1481f71dcde4f589461d0f4d91c53b7adbe82 (patch)
tree0caea05e44bdd8bd454abda632c2698915e8d4c7
parent4b29c8c236d5f5a27a4da749f19668160fdd7146 (diff)
downloadaur-f1d1481f71dcde4f589461d0f4d91c53b7adbe82.tar.gz
Release 1.1.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c41e659ccab..b9b8218bf248 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
pkgbase = genrepass-bin
pkgdesc = Generate a readable password from an ordered list of words extracted from text
- pkgver = 1.1.0
+ pkgver = 1.1.1
pkgrel = 1
url = https://github.com/AlexChaplinBraz/genrepass-cli
arch = x86_64
arch = i686
license = MIT
- depends = gcc-libs
depends = libxcb
+ depends = gcc-libs
depends = glibc
- depends = libxau
- depends = libxau
conflicts = genrepass
conflicts = genrepass-git
- source_x86_64 = https://github.com/AlexChaplinBraz/genrepass-cli/releases/download/1.1.0/genrepass-x86_64-unknown-linux-gnu-1.1.0.tar.gz
- sha256sums_x86_64 = 98a06b8865ed624fa4b491dfc495161a6ffde80a2f4762d23913602d3c3b939f
- source_i686 = https://github.com/AlexChaplinBraz/genrepass-cli/releases/download/1.1.0/genrepass-i686-unknown-linux-gnu-1.1.0.tar.gz
- sha256sums_i686 = 824db896fd09ca7c61d86392c0f7782fdedda5785903de36dd114a2937469550
+ source_x86_64 = https://github.com/AlexChaplinBraz/genrepass-cli/releases/download/1.1.1/genrepass-1.1.1-x86_64-unknown-linux-gnu.tar.gz
+ sha256sums_x86_64 =
+ source_i686 = https://github.com/AlexChaplinBraz/genrepass-cli/releases/download/1.1.1/genrepass-1.1.1-i686-unknown-linux-gnu.tar.gz
+ sha256sums_i686 =
pkgname = genrepass-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 09bde9092e74..b576b7162ebf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Alexander Chaplin Braz <contact@alexchaplinbraz.com>
pkgname='genrepass-bin'
_pkgname='genrepass'
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=1
pkgdesc='Generate a readable password from an ordered list of words extracted from text'
arch=('x86_64' 'i686')
url='https://github.com/AlexChaplinBraz/genrepass-cli'
license=('MIT')
-depends=('gcc-libs' 'libxcb' 'glibc' 'libxau' 'libxau')
+depends=('libxcb' 'gcc-libs' 'glibc')
conflicts=('genrepass' 'genrepass-git')
-source_x86_64=("$url/releases/download/$pkgver/genrepass-x86_64-unknown-linux-gnu-$pkgver.tar.gz")
-source_i686=("$url/releases/download/$pkgver/genrepass-i686-unknown-linux-gnu-$pkgver.tar.gz")
-sha256sums_x86_64=('98a06b8865ed624fa4b491dfc495161a6ffde80a2f4762d23913602d3c3b939f')
-sha256sums_i686=('824db896fd09ca7c61d86392c0f7782fdedda5785903de36dd114a2937469550')
+source_x86_64=("$url/releases/download/$pkgver/$_pkgname-$pkgver-x86_64-unknown-linux-gnu.tar.gz")
+source_i686=("$url/releases/download/$pkgver/$_pkgname-$pkgver-i686-unknown-linux-gnu.tar.gz")
+sha256sums_x86_64=('')
+sha256sums_i686=('')
package() {
- install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "$srcdir/$_pkgname-$pkgver-*/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "$srcdir/$_pkgname-$pkgver-*/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
}