summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHeyCitizen2020-08-01 19:22:23 -0400
committerHeyCitizen2020-08-01 19:22:23 -0400
commit6c28f536383c3fa144230b202f42311d54c52f86 (patch)
treecefdbb34f5e6619e1f411229691581fadd44733c
downloadaur-6c28f536383c3fa144230b202f42311d54c52f86.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
-rw-r--r--gensystray.sample.cfg14
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f39d5624ee4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gensystray-git
+ pkgdesc = Create your own system tray item to run your favorite commands.
+ pkgver = r25.fd5a9b7
+ pkgrel = 1
+ url = https://github.com/dardevelin/gensystray
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc
+ makedepends = git
+ makedepends = pkgconf
+ depends = gtk3
+ depends = sdl2
+ provides = gensystray
+ conflicts = gensystray
+ source = gensystray::git+https://github.com/dardevelin/gensystray.git
+ source = gensystray.sample.cfg
+ sha256sums = SKIP
+ sha256sums = 02b33f2c064c96308ce4754f24f0fad36f8d56c5fbdc55acc34ebc7b09532b42
+
+pkgname = gensystray-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f41407551665
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: HeyCitizen <4637290+InTheMorning@users.noreply.github.com>
+## LICENSE - GPLv3 no later option. Ignore any references to later versions
+
+_pkgname=gensystray
+_install_dir="/usr/share/${_pkgname}/"
+pkgname=${_pkgname}-git
+pkgver=r25.fd5a9b7
+pkgrel=1
+pkgdesc='Create your own system tray item to run your favorite commands.'
+arch=('x86_64')
+url='https://github.com/dardevelin/gensystray'
+license=('GPL3')
+depends=('gtk3' 'sdl2')
+makedepends=('gcc' 'git' 'pkgconf')
+provides=('gensystray')
+conflicts=('gensystray')
+source=("${_pkgname}::git+https://github.com/dardevelin/gensystray.git"
+ 'gensystray.sample.cfg')
+sha256sums=('SKIP'
+ '02b33f2c064c96308ce4754f24f0fad36f8d56c5fbdc55acc34ebc7b09532b42')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ $(cat build_gcc.sh|tr -d '\n') $(pkg-config --cflags --libs gtk+-3.0)
+}
+
+package() {
+ mkdir -p "${pkgdir}${_install_dir}"
+ cd "${_pkgname}"
+ install -D -m755 "${_pkgname}" "${pkgdir}usr/bin/${_pkgname}"
+ install -D -m644 "gensystray_default.png" "${pkgdir}${_install_dir}${_pkgname}.png"
+ install -D -m644 "README.md" "${pkgdir}${_install_dir}README.md"
+ install -D -m644 "../gensystray.sample.cfg" "${pkgdir}${_install_dir}${_pkgname}.sample.cfg"
+ # show configuration notes to the user
+ _ylo="\e[1;33m"
+ _rd="\e[1;31m"
+ _nrml="\e[1;32m"
+ _cfg_dir="~/.config/${_pkgname}/"
+ msg2 "${_rd} Please note:\n\t${_nrml}To get started with gensystray, type:\n\t${_ylo}mkdir -p ${_cfg_dir}\n\t${_nrml}Then copy ${_ylo}${_install_dir}gensystray.sample.cfg ${_nrml}to${_ylo} ${_cfg_dir}${_pkgname}.cfg\n\t${_nrml}and edit it using your favorite text editor."
+}
diff --git a/gensystray.sample.cfg b/gensystray.sample.cfg
new file mode 100644
index 000000000000..3f78f2b100c4
--- /dev/null
+++ b/gensystray.sample.cfg
@@ -0,0 +1,14 @@
+# Specify a 16x16 icon location
+@/usr/share/icons/gensystray.png
+
+# Set the tooltip text in single quotes, ending with a new line
+'Generic System Tray Icon'
+
+# Add items like this:
+[Item name]
+command
+
+# Add separators like this:
+[-]
+-
+