summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Revilla2015-07-02 16:52:21 +0200
committerMiguel Revilla2015-07-02 16:52:21 +0200
commit85672a561d7c0d99e7fb37e3a986ce82c83fa112 (patch)
tree4ededc9245514bb615c05d0d6b8c2ab6e18f454e
downloadaur-85672a561d7c0d99e7fb37e3a986ce82c83fa112.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
-rw-r--r--gentoo-bashrc-2013.080
-rw-r--r--gentoo-bashrc.install22
4 files changed, 144 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a92e6b06005
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gentoo-bashrc
+ pkgdesc = This is Gentoo's BASHRC file, which has very nice color schemes.
+ pkgver = 2013.0
+ pkgrel = 1
+ url = http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html
+ install = gentoo-bashrc.install
+ arch = any
+ license = GPL
+ optdepends = bash: Shell needed to make use of this package
+ source = gentoo-bashrc-2013.0
+ md5sums = 3149b49f29fc9dceb660c4a87b40e8cf
+
+pkgname = gentoo-bashrc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39dd7b6aae08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Miguel Revilla <yo@miguelrevilla.com>
+# Contributor: Jeremy Sands <cto@jeremysands.com>
+pkgname=gentoo-bashrc
+pkgver=2013.0
+pkgrel=1
+pkgdesc="This is Gentoo's BASHRC file, which has very nice color schemes."
+arch=('any')
+url="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+license=('GPL')
+optdepends=('bash: Shell needed to make use of this package')
+source=('gentoo-bashrc-2013.0')
+md5sums=('3149b49f29fc9dceb660c4a87b40e8cf')
+install=${pkgname}.install
+
+package() {
+
+ install -D -m755 gentoo-bashrc-2013.0 "${pkgdir}"/usr/share/gentoo-bashrc/bashrc
+
+ msg "IMPORTANT!!"
+ msg ""
+ msg "To prevent overwriting your existing .bashrc, the file"
+ msg "was installed to /usr/share/gentoo-bashrc/bashrc"
+ msg ""
+ msg "Please examine that file, adding your own important"
+ msg "settings and local variables to it before replacing"
+ msg "your existing bashrc."
+ msg ""
+}
diff --git a/gentoo-bashrc-2013.0 b/gentoo-bashrc-2013.0
new file mode 100644
index 000000000000..d46cd1eb2f5f
--- /dev/null
+++ b/gentoo-bashrc-2013.0
@@ -0,0 +1,80 @@
+# /etc/bash/bashrc
+#
+# This file is sourced by all *interactive* bash shells on startup,
+# including some apparently interactive shells such as scp and rcp
+# that can't tolerate any output. So make sure this doesn't display
+# anything or bad things will happen !
+
+
+# Test for an interactive shell. There is no need to set anything
+# past this point for scp and rcp, and it's important to refrain from
+# outputting anything in those cases.
+if [[ $- != *i* ]] ; then
+ # Shell is non-interactive. Be done now!
+ return
+fi
+
+# Bash won't get SIGWINCH if another process is in the foreground.
+# Enable checkwinsize so that bash will check the terminal size when
+# it regains control. #65623
+# http://cnswww.cns.cwru.edu/~chet/bash/FAQ (E11)
+shopt -s checkwinsize
+
+# Enable history appending instead of overwriting. #139609
+shopt -s histappend
+
+# Change the window title of X terminals
+case ${TERM} in
+ xterm*|rxvt*|Eterm|aterm|kterm|gnome*|interix)
+ PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}\007"'
+ ;;
+ screen)
+ PROMPT_COMMAND='echo -ne "\033_${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}\033\\"'
+ ;;
+esac
+
+use_color=false
+
+# Set colorful PS1 only on colorful terminals.
+# dircolors --print-database uses its own built-in database
+# instead of using /etc/DIR_COLORS. Try to use the external file
+# first to take advantage of user additions. Use internal bash
+# globbing instead of external grep binary.
+safe_term=${TERM//[^[:alnum:]]/?} # sanitize TERM
+match_lhs=""
+[[ -f ~/.dir_colors ]] && match_lhs="${match_lhs}$(<~/.dir_colors)"
+[[ -f /etc/DIR_COLORS ]] && match_lhs="${match_lhs}$(</etc/DIR_COLORS)"
+[[ -z ${match_lhs} ]] \
+ && type -P dircolors >/dev/null \
+ && match_lhs=$(dircolors --print-database)
+[[ $'\n'${match_lhs} == *$'\n'"TERM "${safe_term}* ]] && use_color=true
+
+if ${use_color} ; then
+ # Enable colors for ls, etc. Prefer ~/.dir_colors #64489
+ if type -P dircolors >/dev/null ; then
+ if [[ -f ~/.dir_colors ]] ; then
+ eval $(dircolors -b ~/.dir_colors)
+ elif [[ -f /etc/DIR_COLORS ]] ; then
+ eval $(dircolors -b /etc/DIR_COLORS)
+ fi
+ fi
+
+ if [[ ${EUID} == 0 ]] ; then
+ PS1='\[\033[01;31m\]\h\[\033[01;34m\] \W \$\[\033[00m\] '
+ else
+ PS1='\[\033[01;32m\]\u@\h\[\033[01;34m\] \w \$\[\033[00m\] '
+ fi
+
+ alias ls='ls --color=auto'
+ alias grep='grep --colour=auto'
+else
+ if [[ ${EUID} == 0 ]] ; then
+ # show root@ when we don't have colors
+ PS1='\u@\h \W \$ '
+ else
+ PS1='\u@\h \w \$ '
+ fi
+fi
+
+# Try to keep environment pollution down, EPA loves us.
+unset use_color safe_term match_lhs
diff --git a/gentoo-bashrc.install b/gentoo-bashrc.install
new file mode 100644
index 000000000000..85f772e713ba
--- /dev/null
+++ b/gentoo-bashrc.install
@@ -0,0 +1,22 @@
+pkgname=gentoo-bashrc
+
+post_install() {
+ cat << _EOF
+
+==> IMPORTANT!!!
+==> To prevent overwriting your existing .bashrc, the file
+==> was installed to /usr/share/gentoo-bashrc/bashrc
+==>
+==> Please examine that file, adding your own important
+==> settings and local variables to it before replacing your
+==> existing bashrc. Gentoo's bashrc also includes a
+==> color scheme for root, so you may consider copying it to
+==> /root/.bashrc after also copying any local variables there
+==> to the new .bashrc
+
+_EOF
+}
+
+post_upgrade() {
+ post_install $1
+}