summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHao Zhang2017-06-13 16:05:29 -0600
committerHao Zhang2017-06-13 16:05:29 -0600
commit9bae28dbfab1de5a31a32bc5275a0fcbd55278bb (patch)
tree4d27dedd66f6d6b53e885b011eeaed0914c7c596
downloadaur-9bae28dbfab1de5a31a32bc5275a0fcbd55278bb.tar.gz
Initial Upload
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD24
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bbbb5854b68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = genx
+ pkgdesc = X-ray and Neutron reflectivity fitting software
+ pkgver = 2.4.9
+ pkgrel = 1
+ url = http://genx.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL v3
+ makedepends = cython
+ makedepends = git
+ depends = python
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-matplotlib
+ depends = python-h5py
+ depends = wxpython-phoenix
+ depends = python-appdirs
+ options = !libtool
+ source = https://github.com/haozhangphd/genx-py3/archive/v2.4.9.tar.gz
+ sha256sums = 52d760cd032492c45fa02b7c707b2af9de03c05c949dc0dced86b9aecce1ef4f
+
+pkgname = genx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99a7a5db3b11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Hao Zhang <hao [at] hao-zhang [dot] com>
+
+pkgname=genx
+pkgver=2.4.9
+pkgrel=1
+pkgdesc="X-ray and Neutron reflectivity fitting software"
+arch=("i686" "x86_64")
+url="http://genx.sourceforge.net/"
+license=("GPL v3")
+options=(!libtool)
+depends=("python" "python-numpy" "python-scipy" "python-matplotlib" "python-h5py" "wxpython-phoenix" "python-appdirs")
+makedepends=("cython" "git")
+source=(https://github.com/haozhangphd/genx-py3/archive/v$pkgver.tar.gz)
+sha256sums=("52d760cd032492c45fa02b7c707b2af9de03c05c949dc0dced86b9aecce1ef4f")
+
+build() {
+ cd "$srcdir"/genx-py3-"$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/genx-py3-"$pkgver"
+ python setup.py install --prefix=usr/ --root=$pkgdir
+}