summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValérie Roux2023-02-25 21:55:11 +0100
committerValérie Roux2023-02-25 21:55:11 +0100
commit4fe2dc511546eae4c27b1ed275720b568cf5abd9 (patch)
treebc6bc142e61e2c7b5a5141e6e13935a26d49611d
downloadaur-4fe2dc511546eae4c27b1ed275720b568cf5abd9.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD22
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4489bcbc2d1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = geobug
+ pkgdesc = Displays Global Navigation Satellite System (GNSS: GPS, Galileo, Glonass etc.) information obtained from NMEA sources and saves your tracks
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://codeberg.org/tpikonen/geobug
+ arch = any
+ license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-gobject
+ depends = libhandy
+ depends = python-pydbus
+ depends = python-gpxpy
+ depends = geoclue
+ source = https://codeberg.org/tpikonen/geobug/archive/0.1.4.tar.gz
+ sha512sums = 682430ca75c7953e3220b3a9c17b92f13816f8d43bdb1d2910b73947e4282d2bb56d693096d4c51ce045ac563cb7dd12a8c4f62f681bdc3494516cc1c669f009
+
+pkgname = geobug
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..12dc576dd5a6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+
+!*.patch
+!.SRCINFO
+!PKGBUILD
+
+!.gitignore
+!README.md
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..999ec28a51c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=geobug
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="Displays Global Navigation Satellite System (GNSS: GPS, Galileo, Glonass etc.) information obtained from NMEA sources and saves your tracks"
+arch=('any')
+url="https://codeberg.org/tpikonen/$pkgname"
+license=('GPL3')
+depends=(python-gobject libhandy python-pydbus python-gpxpy geoclue)
+makedepends=(python-build python-installer python-wheel)
+source=("https://codeberg.org/tpikonen/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('682430ca75c7953e3220b3a9c17b92f13816f8d43bdb1d2910b73947e4282d2bb56d693096d4c51ce045ac563cb7dd12a8c4f62f681bdc3494516cc1c669f009')
+
+
+build() {
+ cd "$pkgname"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}