diff options
author | Piroro-hs | 2025-03-23 02:51:05 +0900 |
---|---|---|
committer | Piroro-hs | 2025-03-23 02:51:05 +0900 |
commit | 111d81a54cf343824b5bc884fa071c593cf2eda3 (patch) | |
tree | ceec02d0f07e23899a7daca7d5336efcfc555875 | |
parent | f2e1c31ac99f94485f3fca6eca90ca098b5e7dc7 (diff) | |
download | aur-111d81a54cf343824b5bc884fa071c593cf2eda3.tar.gz |
Fix indentation
-rw-r--r-- | PKGBUILD | 40 |
1 files changed, 20 insertions, 20 deletions
@@ -9,14 +9,14 @@ url="https://github.com/Grollicus/${pkgname%-git}" license=('GPL-3.0-or-later') groups=() depends=('gcc-libs' - 'glibc' + 'glibc' 'libdbus-1.so') makedepends=('cargo' - 'git') + 'git') provides=('geoclue' - 'geoclue2') + 'geoclue2') conflicts=('geoclue' - 'geoclue2') + 'geoclue2') replaces=() backup=("etc/${pkgname%-git}.toml") options=() @@ -26,29 +26,29 @@ noextract=() sha256sums=('SKIP') pkgver() { - cd "$pkgname" - local ver=$(git describe --long 2> /dev/null) - if [ -z "$ver" ]; then - ver="0-$(git rev-list --count HEAD)-g$(git rev-parse --short HEAD)" - fi - echo "$ver" | sed 's/\([^-]*-g\)/r\1/;s/-/./g' + cd "$pkgname" + local ver=$(git describe --long 2> /dev/null) + if [ -z "$ver" ]; then + ver="0-$(git rev-list --count HEAD)-g$(git rev-parse --short HEAD)" + fi + echo "$ver" | sed 's/\([^-]*-g\)/r\1/;s/-/./g' } prepare() { - cd "$pkgname" - cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')" + cd "$pkgname" + cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')" } build() { - cd "$pkgname" - CARGO_TARGET_DIR=target cargo build --frozen --release + cd "$pkgname" + CARGO_TARGET_DIR=target cargo build --frozen --release } package() { - cd "$pkgname" - install -Dm755 "target/release/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}" - install -Dm644 "${pkgname%-git}.service" "$pkgdir/usr/lib/systemd/system/${pkgname%-git}.service" - install -Dm644 org.freedesktop.GeoClue2.service "$pkgdir/usr/share/dbus-1/system-services/org.freedesktop.GeoClue2.service" - install -Dm644 org.freedesktop.GeoClue2.conf "$pkgdir/usr/share/dbus-1/system.d/org.freedesktop.GeoClue2.conf" - install -Dm644 config.default.toml "$pkgdir/etc/${pkgname%-git}.toml" + cd "$pkgname" + install -Dm755 "target/release/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}" + install -Dm644 "${pkgname%-git}.service" "$pkgdir/usr/lib/systemd/system/${pkgname%-git}.service" + install -Dm644 org.freedesktop.GeoClue2.service "$pkgdir/usr/share/dbus-1/system-services/org.freedesktop.GeoClue2.service" + install -Dm644 org.freedesktop.GeoClue2.conf "$pkgdir/usr/share/dbus-1/system.d/org.freedesktop.GeoClue2.conf" + install -Dm644 config.default.toml "$pkgdir/etc/${pkgname%-git}.toml" } |