summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2018-02-12 13:59:57 +0100
committerLuca Weiss2018-02-12 13:59:57 +0100
commite0f94c2ca14234677da6256e3b3a6312d6921057 (patch)
treed91b234507a26239e0f7f408b429e83f074cd494
downloadaur-e0f94c2ca14234677da6256e3b3a6312d6921057.tar.gz
Initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD46
-rw-r--r--geogebra40
-rw-r--r--geogebra-mime.xml27
4 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7dfe751c8eec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = geogebra-5
+ pkgdesc = Dynamic mathematics software with interactive graphics, algebra and spreadsheet
+ pkgver = 5.0.431.0
+ pkgrel = 1
+ url = http://www.geogebra.org/
+ arch = any
+ license = GPL3
+ license = CCPL:by-sa
+ license = CCPL:by-nc
+ makedepends = gendesk
+ depends = desktop-file-utils
+ depends = gsl
+ depends = hicolor-icon-theme
+ depends = java-runtime=8
+ depends = shared-mime-info
+ depends = xdg-utils
+ provides = geogebra
+ conflicts = geogebra
+ source = https://download.geogebra.org/installers/5.0/GeoGebra-Linux-Portable-5-0-431-0.tar.bz2
+ source = https://static.geogebra.org/images/geogebra-logo.svg
+ source = geogebra
+ source = geogebra-mime.xml
+ sha512sums = 4b549f46a3f91c0beb4cba31a2eeb0efd4370288ef1036b934b59632cea09a3559f8e89bbe7f4702545a337ff6565db077d836913b51d801e89c70fe5a62d892
+ sha512sums = a946acb8867f497c68ce6f8fff8172da4a43a9ca118aafcc5ac414318fd52c4bc6ada387bdfa296f0ff2e1d7411ae345b61197b4adaa3f54299aab837647df55
+ sha512sums = f5d6f3fe17638f4521b0a00d6d077a5c509984bd8f7cb39c28e412b7384ec129c6595400e7ae4cb5ba05f1673eb46d8f6c56db1b4145afb35797a1d0a170965d
+ sha512sums = 415e73ff15524d5e81b05cf4c31241f4e21a4eedcef0a11e5af82423f9a7c2cbf632e9ee1e86b4cc60ebc566472462979a65cb7f3cfc9f94243fb545ac042a0f
+
+pkgname = geogebra-5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1beb13a42b00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# $Id$
+# Contributor: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski at archlinux dot org>
+# Contributor: Felipe Hommen <felibank at gmail dot com>
+# Contributor: moostik <mooostik at gmail dot com>
+
+pkgname=geogebra-5
+pkgver=5.0.431.0
+pkgrel=1
+pkgdesc="Dynamic mathematics software with interactive graphics, algebra and spreadsheet"
+arch=('any')
+url='http://www.geogebra.org/'
+license=('GPL3' 'CCPL:by-sa' 'CCPL:by-nc')
+depends=('desktop-file-utils' 'gsl' 'hicolor-icon-theme' 'java-runtime=8'
+ 'shared-mime-info' 'xdg-utils')
+makedepends=('gendesk')
+provides=("${pkgname//-5/}")
+conflicts=("${pkgname//-5/}")
+source=("https://download.geogebra.org/installers/5.0/GeoGebra-Linux-Portable-${pkgver//./-}.tar.bz2"
+ "https://static.geogebra.org/images/geogebra-logo.svg"
+ "geogebra"
+ "geogebra-mime.xml")
+
+prepare() {
+ gendesk -f -n --pkgname "${pkgname//-5/}" --pkgdesc "${pkgdesc}" \
+ --name="GeoGebra" \
+ --categories="Education;Science;Math" \
+ --mimetypes="application/vnd.geogebra.file;application/vnd.geogebra.tool"
+}
+
+package() {
+ cd "GeoGebra-Linux-Portable-${pkgver//./-}"
+
+ install -Dm755 "${srcdir}/geogebra" "${pkgdir}/usr/bin/geogebra"
+ install -dm755 "${pkgdir}/usr/share/geogebra"
+ install "geogebra/"* -t "${pkgdir}/usr/share/geogebra/"
+
+ install -Dm644 "${srcdir}/geogebra.desktop" "${pkgdir}/usr/share/applications/geogebra.desktop"
+ install -Dm644 "${srcdir}/geogebra-logo.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/geogebra.svg"
+ install -Dm644 "${srcdir}/geogebra-mime.xml" "${pkgdir}/usr/share/mime/packages/geogebra.xml"
+}
+
+sha512sums=('4b549f46a3f91c0beb4cba31a2eeb0efd4370288ef1036b934b59632cea09a3559f8e89bbe7f4702545a337ff6565db077d836913b51d801e89c70fe5a62d892'
+ 'a946acb8867f497c68ce6f8fff8172da4a43a9ca118aafcc5ac414318fd52c4bc6ada387bdfa296f0ff2e1d7411ae345b61197b4adaa3f54299aab837647df55'
+ 'f5d6f3fe17638f4521b0a00d6d077a5c509984bd8f7cb39c28e412b7384ec129c6595400e7ae4cb5ba05f1673eb46d8f6c56db1b4145afb35797a1d0a170965d'
+ '415e73ff15524d5e81b05cf4c31241f4e21a4eedcef0a11e5af82423f9a7c2cbf632e9ee1e86b4cc60ebc566472462979a65cb7f3cfc9f94243fb545ac042a0f')
diff --git a/geogebra b/geogebra
new file mode 100644
index 000000000000..eb41e11a7bdb
--- /dev/null
+++ b/geogebra
@@ -0,0 +1,40 @@
+#!/bin/sh
+# run application with java env = 8
+
+GG_PATH="/usr/share"
+export GG_CONFIG_PATH="${HOME}"
+GG_EXECUTABLE="${GG_PATH}/geogebra/geogebra"
+GG_JAVA_VERSION="8"
+
+run_gg() {
+ exec "${GG_EXECUTABLE}" "$@"
+ exit 0
+}
+
+# check JAVA_HOME first
+if test ! -z "${JAVA_HOME}"; then
+ if test "${JAVA_HOME#*$GG_JAVA_VERSION}" != "${JAVA_HOME}"; then
+ # system environment variable set to required, do nothing
+ echo "Using java environment from JAVA_HOME: ${JAVA_HOME}" >&2
+ run_gg
+ else
+ # unset JAVA_HOME
+ echo "Unset JAVA_HOME for this run: ${JAVA_HOME}" >&2
+ unset JAVA_HOME
+ fi
+fi
+
+# check current environment
+if archlinux-java status | grep "default" | grep -q "${GG_JAVA_VERSION}"; then
+ # required java version is set to default, do nothing
+ echo "Using system enabled java environment" >&2
+ run_gg
+fi
+
+# find valid environment
+GG_JAVA_ENV="$(archlinux-java status | grep "${GG_JAVA_VERSION}" | awk '{ print $1 }')"
+# for some env it returns like java-8-openjdk/jre
+GG_JAVA_ENV="${GG_JAVA_ENV%/*}"
+export PATH="/usr/lib/jvm/${GG_JAVA_ENV}/jre/bin/:${PATH}"
+echo "Run with exported ${GG_JAVA_ENV}" >&2
+run_gg
diff --git a/geogebra-mime.xml b/geogebra-mime.xml
new file mode 100644
index 000000000000..8b27d6616baa
--- /dev/null
+++ b/geogebra-mime.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/vnd.geogebra.file">
+ <comment>GeoGebra worksheet</comment>
+ <comment xml:lang="cs">Pracovní list GeoGebry</comment>
+ <comment xml:lang="de">GeoGebra-Arbeitsblatt</comment>
+ <comment xml:lang="es">Archivo GeoGebra</comment>
+ <comment xml:lang="fr">Feuille de travail GeoGebra </comment>
+ <comment xml:lang="hi">जीओ-जेब्रा कार्य-पत्र</comment>
+ <comment xml:lang="it">Foglio di lavoro GeoGebra </comment>
+ <comment xml:lang="pt-BR">Planilha GeoGebra</comment>
+ <sub-class-of type="application/zip"/>
+ <glob pattern="*.ggb"/>
+ </mime-type>
+ <mime-type type="application/vnd.geogebra.tool">
+ <comment>GeoGebra tool</comment>
+ <comment xml:lang="cs">Nástroj GeoGebry</comment>
+ <comment xml:lang="de">GeoGebra-Werkzeug</comment>
+ <comment xml:lang="es">Herramienta GeoGebra</comment>
+ <comment xml:lang="fr">Outil GeoGebra</comment>
+ <comment xml:lang="hi">जीओ-जेब्रा साधन</comment>
+ <comment xml:lang="it">Strumento GeoGebra</comment>
+ <comment xml:lang="pt-BR">Ferramenta GeoGebra</comment>
+ <sub-class-of type="application/zip"/>
+ <glob pattern="*.ggt"/>
+ </mime-type>
+</mime-info>