summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2019-05-13 22:23:07 +0200
committeregnappahz2019-05-13 22:23:07 +0200
commit8b7f93edf74286dd6d2f120c267d740c9d645839 (patch)
tree2ccf38872804a4ddecd31d792a54e4c686af21a9
parent277c4fb792d5ecd4dd034262c3d05d7f5081bb89 (diff)
downloadaur-8b7f93edf74286dd6d2f120c267d740c9d645839.tar.gz
Updated deprecated dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1288a2c3f403..bfbd8b8fd606 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,12 +4,14 @@ pkgbase = geoipdatabase_reloaded
url = https://dev.maxmind.com/geoip/geoip2/geolite2/
arch = x86_64
license = Creative Commons Attribution-ShareAlike 4.0 International License
- checkdepends = python2
- checkdepends = geoip
+ makedepends = python2
+ depends = geoip
source = http://nhameh.ovh/varia/python2-pygeoip-0.3.2-4-any.pkg.tar.xz
+ source = http://nhameh.ovh/varia/python2-ipaddr-2.2.0-1-any.pkg.tar.xz
source = git+https://github.com/sherpya/geolite2legacy/
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = geoipdatabase_reloaded
pkgdesc = Compiles the newest geoip databases for counties and cities from maxmind and installs them on your system
diff --git a/PKGBUILD b/PKGBUILD
index 2ea8fc427411..b792ff8f54a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,8 @@ pkgrel=1
arch=('x86_64')
url="https://dev.maxmind.com/geoip/geoip2/geolite2/"
license=('Creative Commons Attribution-ShareAlike 4.0 International License')
-checkdepends=('python2' 'geoip')
+makedepends=('python2')
+depends=('geoip')
# We all love colors. Stop pretending you don't.
BRED="\033[1;31m"
@@ -16,12 +17,14 @@ BGREEN='\033[1;92m'
NOCOLOR='\033[0m'
- #the deprecated package for parsing the geoip data
+ #the deprecated packages for parsing the geoip data
source=('http://nhameh.ovh/varia/python2-pygeoip-0.3.2-4-any.pkg.tar.xz'
+ 'http://nhameh.ovh/varia/python2-ipaddr-2.2.0-1-any.pkg.tar.xz'
# the main kernel config files
'git+https://github.com/sherpya/geolite2legacy/')
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP')
pkgver() {
echo $pkgver
@@ -39,10 +42,10 @@ prepare() {
echo "1.."
sleep 1
- if [ "$(pacman -Q python2-pygeoip)" == "" ]; then
- echo -e "${BYELLOW}Now installing a ${BRED}(missing in the arch repo??) ${BORANGE}package${BYELLOW} to parse the geoipfiles..."
- echo -e "${BORANGE}python2-pygeoip${BYELLOW} got completely deprecated for undisclosed ${BRED}(as usual)${BYELLOW} reasons, so we need to install this here from an external source.${NOCOLOR}"
- sudo pacman --noconfirm -U ../python2-pygeoip-0.3.2-4-any.pkg.tar.xz
+ if [ "$(pacman -Q python2-pygeoip)" == "" ] || [ "$(pacman -Q python2-ipaddr)" == "" ]; then
+ echo -e "${BYELLOW}Now installing ${BRED}(missing in the arch repos) ${BORANGE}packages${BYELLOW} to parse the geoipfiles..."
+ echo -e "${BORANGE}python2-pygeoip and python2-ipaddr ${BYELLOW} got completely deprecated, so we need to install this here from an external source.${NOCOLOR}"
+ sudo pacman --noconfirm -U ../python2-pygeoip-0.3.2-4-any.pkg.tar.xz ../python2-ipaddr-2.2.0-1-any.pkg.tar.xz
fi
if [ ! -d CSVzips ]; then
mkdir CSVzips