summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2019-05-11 19:45:49 +0200
committeregnappahz2019-05-11 19:45:49 +0200
commitd502d39ee6c5e48c22dbb8be6bcd57b242092345 (patch)
tree59b0a023b24e2de4da1c5b442653da0ae9f90d40
parenteabda8db1dfb6ac96f2136e84c1137abeee66c3f (diff)
downloadaur-d502d39ee6c5e48c22dbb8be6bcd57b242092345.tar.gz
Fixed License, added mentions, fixed dependencychecks
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0179fafa292d..ac54d79dbc69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = geoipdatabase_reloaded
- pkgver = 0.9.1
- pkgrel = 2
+ pkgver = 0.9.2
+ pkgrel = 1
url = https://dev.maxmind.com/geoip/geoip2/geolite2/
arch = x86_64
- license = GPL2
- makedepends = python2
+ license = Creative Commons Attribution-ShareAlike 4.0 International License
+ checkdepends = python2
+ checkdepends = geoip
source = http://nhameh.ovh/varia/python2-pygeoip-0.3.2-4-any.pkg.tar.xz
source = git+https://github.com/sherpya/geolite2legacy/
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f6847fb4b0e5..e1dcb7da9665 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Steven De Bondt <egnappah at gmail dot com>
pkgbase=geoipdatabase_reloaded
-pkgver=0.9.1
-pkgrel=2
+pkgver=0.9.2
+pkgrel=1
arch=('x86_64')
url="https://dev.maxmind.com/geoip/geoip2/geolite2/"
-license=('GPL2')
-makedepends=('python2')
+license=('Creative Commons Attribution-ShareAlike 4.0 International License')
+checkdepends=('python2' 'geoip')
# We all love colors. Stop pretending you don't.
BRED="\033[1;31m"
@@ -29,6 +29,16 @@ pkgver() {
prepare() {
+ echo -e "${BRED}This product includes GeoLite2 data created by MaxMind, available from https://www.maxmind.com${NOCOLOR}"
+ echo -e "${BGREEN}Got it?${NOCOLOR}"
+ sleep 1
+ echo -n "3.."
+ sleep 1
+ echo -n "2.."
+ sleep 1
+ echo "1.."
+ sleep 1
+
if [ "$(pacman -Q python2-pygeoip)" == "" ]; then
echo -e "${BYELLOW}Now installing a ${BRED}(missing in the arch repo??) ${BORANGE}package${BYELLOW} to parse the geoipfiles..."
echo -e "${BORANGE}python2-pygeoip${BYELLOW} got completely deprecated for undisclosed ${BRED}(as usual)${BYELLOW} reasons, so we need to install this here from an external source.${NOCOLOR}"