summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2019-05-11 16:07:39 +0200
committeregnappahz2019-05-11 16:07:39 +0200
commite71c6e3e38f123edf3ad62e7e18be24294c174c0 (patch)
treea39eb041e6efb7874b41cebe150b9bd3696d0ee9
parent703fe785229f27b612a23231cfbf25cc9e9d9385 (diff)
downloadaur-e71c6e3e38f123edf3ad62e7e18be24294c174c0.tar.gz
added ASNum reference file
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d837a5e2550..99d1c645d889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -45,13 +45,14 @@ prepare() {
echo -e "${BYELLOW}Downloading the ${BGREEN}newest${BYELLOW} GeoIP CSV files from maxmind...${NOCOLOR}"
wget -P CSVzips/ https://geolite.maxmind.com/download/geoip/database/GeoLite2-City-CSV.zip
wget -P CSVzips/ https://geolite.maxmind.com/download/geoip/database/GeoLite2-Country-CSV.zip
- #wget -P CSVzips/ https://geolite.maxmind.com/download/geoip/database/GeoLite2-ASN-CSV.zip
+ wget -P CSVzips/ https://geolite.maxmind.com/download/geoip/database/GeoLite2-ASN-CSV.zip
}
build() {
echo -e "${BYELLOW}Now ${BGREEN}building${BYELLOW} the .DAT files for the geoip database.${NOCOLOR}"
python2 geolite2legacy/geolite2legacy.py -i CSVzips/GeoLite2-Country-CSV.zip -f geolite2legacy/geoname2fips.csv -o output/GeoIP.dat
python2 geolite2legacy/geolite2legacy.py -i CSVzips/GeoLite2-City-CSV.zip -f geolite2legacy/geoname2fips.csv -o output/GeoIPCity.dat
+ python2 geolite2legacy/geolite2legacy.py -i CSVzips/GeoLite2-ASN-CSV.zip -f geolite2legacy/geoname2fips.csv -o output/GeoIPASNum.dat
}
package() {