summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Marien2015-10-01 12:29:05 +0200
committerFrank Marien2015-10-01 12:29:05 +0200
commit7f79979b67ba84e3a3cecea14b0316539c81c41f (patch)
tree8cb5c6d22f90117fc36e1202f5dedbdd84cfb475
downloadaur-7f79979b67ba84e3a3cecea14b0316539c81c41f.tar.gz
initial checkin
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
-rw-r--r--geoipupdate.install22
-rw-r--r--geoipupdate.service11
-rw-r--r--geoipupdate.timer10
6 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b11a71897d5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = geoipupdate
+ pkgdesc = Automatic updates of MaxMind GeoIP2 and GeoIP Legacy binary databases
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = http://dev.maxmind.com/geoip/geoipupdate/
+ install = geoipupdate.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = curl
+ provides = geoipupdate
+ source = https://github.com/maxmind/geoipupdate/releases/download/v2.2.1/geoipupdate-2.2.1.tar.gz
+ source = geoipupdate.install
+ source = geoipupdate.service
+ source = geoipupdate.timer
+ sha512sums = 5d28803353badd4d00a9174202912524f31e057ef4f5381360c16909fbccce3033f5ad7ec9c55963b70c0bbdb74589932bde36ea9b34f2a0632c504c1718dd85
+ sha512sums = 660d22d5dc86d6c2a30456e72b6d121d093d40fc1e27f8250d33675b4752c5bb66aef371a17a7177a926df27a7149bc63118248c6048078e861ce420bd875583
+ sha512sums = 20eba13c38f54fb32dc3ed6535c4ab62a7292b0f638d03c9ab5b3d3d968e4324795953fe0ec1596e3e69b279e8de24a5608f1484d68dd9b5d35f11a56b1dbd72
+ sha512sums = 1d865e31eccd7597093df83da05f3866a361e9f68bcc1f1fa10d72cc2fae8a789d9c2cee445cf81f2384a3415ebd12d2c485d6dfe8401ea005f7c111a6331dd2
+
+pkgname = geoipupdate
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3857ddd1dd4c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.xz
+*.tar.gz
+pkg
+src
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd33a794a690
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: frank AT apsu DOT be
+pkgname=geoipupdate
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="Automatic updates of MaxMind GeoIP2 and GeoIP Legacy binary databases"
+license=('GPL2')
+arch=(i686 x86_64)
+url="http://dev.maxmind.com/geoip/geoipupdate/"
+
+depends=(curl)
+provides=(geoipupdate)
+install=geoipupdate.install
+
+source=("https://github.com/maxmind/geoipupdate/releases/download/v$pkgver/geoipupdate-$pkgver.tar.gz"
+ "geoipupdate.install"
+ "geoipupdate.service"
+ "geoipupdate.timer"
+)
+
+sha512sums=('5d28803353badd4d00a9174202912524f31e057ef4f5381360c16909fbccce3033f5ad7ec9c55963b70c0bbdb74589932bde36ea9b34f2a0632c504c1718dd85'
+ '660d22d5dc86d6c2a30456e72b6d121d093d40fc1e27f8250d33675b4752c5bb66aef371a17a7177a926df27a7149bc63118248c6048078e861ce420bd875583'
+ '20eba13c38f54fb32dc3ed6535c4ab62a7292b0f638d03c9ab5b3d3d968e4324795953fe0ec1596e3e69b279e8de24a5608f1484d68dd9b5d35f11a56b1dbd72'
+ '1d865e31eccd7597093df83da05f3866a361e9f68bcc1f1fa10d72cc2fae8a789d9c2cee445cf81f2384a3415ebd12d2c485d6dfe8401ea005f7c111a6331dd2')
+
+build() {
+ cd "$srcdir/geoipupdate-$pkgver"
+ ./configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --sysconfdir=/etc/geoipupdate
+ make
+}
+
+package() {
+ cd "$srcdir/geoipupdate-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir/usr/lib/systemd/system"
+ cp "$srcdir/geoipupdate.service" "$pkgdir/usr/lib/systemd/system/"
+ cp "$srcdir/geoipupdate.timer" "$pkgdir/usr/lib/systemd/system/"
+}
diff --git a/geoipupdate.install b/geoipupdate.install
new file mode 100644
index 000000000000..e73ec8c45463
--- /dev/null
+++ b/geoipupdate.install
@@ -0,0 +1,22 @@
+post_install() {
+ cat <<EOF
+**** NOTICE ****
+*
+* To use the geoipupdate package,
+* you need to add configuration data to /etc/geoipupdate/GeoIP.conf.
+*
+* Please See <http://dev.maxmind.com/geoip/geoipupdate/>
+*
+* To schedule automatic updates, start and enable
+*
+* geoipupdate.timer
+*
+* $ sudo systemctl start geoipupdate.timer
+* $ sudo systemctl enable geoipupdate.timer
+*
+* by default, this will run geoipupdate weekly, and one minute
+* after every reboot.
+*
+*
+EOF
+}
diff --git a/geoipupdate.service b/geoipupdate.service
new file mode 100644
index 000000000000..d49d4d12117a
--- /dev/null
+++ b/geoipupdate.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=GeoIPUpdate
+Wants=network.target
+After=network.target
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/geoipupdate
+
+[Install]
+WantedBy=multi-user.target
diff --git a/geoipupdate.timer b/geoipupdate.timer
new file mode 100644
index 000000000000..42e2e01ca234
--- /dev/null
+++ b/geoipupdate.timer
@@ -0,0 +1,10 @@
+[Unit]
+Description=Run GeoIP update weekly and on boot
+
+[Timer]
+OnBootSec=1min
+OnUnitActiveSec=1w
+
+[Install]
+WantedBy=timers.target
+