summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2018-06-04 16:49:08 +0200
committerSimon Legner2018-06-04 16:49:42 +0200
commit43d0ca78863e341b7346b45e53a59e21edf2c3bb (patch)
tree8f59ceda28a82a6d0952ea05b7153a5f93a2a919
parent5d240d6acffc4c7deb4566a36589661c2d028c60 (diff)
downloadaur-43d0ca78863e341b7346b45e53a59e21edf2c3bb.tar.gz
Rename to geojsonhint
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b6e5dd887dd..65322d38d384 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
-# Generated by mksrcinfo v8
-# Sat Mar 17 22:08:09 UTC 2018
-pkgbase = nodejs-geojsonhint
+pkgbase = geojsonhint
pkgdesc = Validate and sanity-check geojson files (geojsonlint)
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mapbox/geojsonhint#readme
arch = any
+ license = ISC
+ makedepends = npm
depends = nodejs
- depends = npm
+ replaces = nodejs-geojsonhint
noextract = geojsonhint-2.1.0.tgz
source = https://registry.npmjs.org/@mapbox/geojsonhint/-/geojsonhint-2.1.0.tgz
sha256sums = 9067522a29396f212b5ffd592474537e9ff3151df050fc2c77f629d13fb7ac68
-pkgname = nodejs-geojsonhint
+pkgname = geojsonhint
diff --git a/PKGBUILD b/PKGBUILD
index d0bf9d17bd29..1e24823233c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-_npmprefix=@mapbox
-_npmname=geojsonhint
-_npmver=2.1.0
-pkgname=nodejs-geojsonhint # All lowercase
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+pkgname=geojsonhint
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Validate and sanity-check geojson files (geojsonlint)"
arch=(any)
url="https://github.com/mapbox/geojsonhint#readme"
-license=()
-depends=('nodejs' 'npm' )
-optdepends=()
-source=(https://registry.npmjs.org/$_npmprefix/$_npmname/-/$_npmname-$_npmver.tgz)
-noextract=($_npmname-$_npmver.tgz)
+license=('ISC')
+depends=('nodejs')
+makedepends=('npm')
+source=(https://registry.npmjs.org/@mapbox/$pkgname/-/$pkgname-$pkgver.tgz)
+noextract=($pkgname-$pkgver.tgz)
+replaces=('nodejs-geojsonhint')
package() {
cd $srcdir
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p $_npmdir
cd $_npmdir
- npm install -g --prefix "$pkgdir/usr" $_npmprefix/$_npmname@$_npmver
+ npm install -g --prefix "$pkgdir/usr" @mapbox/$pkgname@$pkgver
+ find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+ install -Dm755 "$_npmdir/@mapbox/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: