summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892016-07-12 10:11:46 +0200
committerPhoton892016-07-12 10:11:46 +0200
commit2de11e04a531b9b1db55778f1ab23bebb46adccb (patch)
treeca3733d0f9ef7c59ef5ebf79c581e75c4e2833a6
parent5a9b283897dbc4bb4626cac5f39fa27807557efa (diff)
downloadaur-2de11e04a531b9b1db55778f1ab23bebb46adccb.tar.gz
Update to 0.14
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
-rw-r--r--deps.patch9
-rw-r--r--desktop.patch13
-rw-r--r--make.patch16
-rw-r--r--x11.patch8
6 files changed, 67 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1904f5973df..4eca998643d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = geomspace
pkgdesc = A browser for geometric (i.e. Euclidean, Riemann, Minkowski) spaces
- pkgver = 0.13.1
+ pkgver = 0.14
pkgrel = 1
url = https://sourceforge.net/projects/geomspace/
arch = i686
@@ -9,22 +9,22 @@ pkgbase = geomspace
depends = libxpm
depends = mesa
depends = fltk
- source = http://downloads.sourceforge.net/project/geomspace/0.13/GeomSpace-0.13.1-src.tar.gz
+ source = http://downloads.sourceforge.net/project/geomspace/0.14/GeomSpace-0.14-src.tar.gz
source = http://downloads.sourceforge.net/project/geomspace/Theory/UniformGeomSpace-2010.11.02-en.pdf
source = http://sourceforge.net/projects/geomspace/files/Models/5Cubes.gmsp
source = http://sourceforge.net/projects/geomspace/files/Models/5Tetra.gmsp
source = make.patch
- source = geomspace.png
- source = geomspace.desktop
- source = linux.mk
- md5sums = 822c6732db58fd844413fa001ef690fb
+ source = x11.patch
+ source = deps.patch
+ source = desktop.patch
+ md5sums = 00107ea0f443c1b9f800876b3b5d1342
md5sums = 14560f6f2cba975be1ba8d047b5acec5
md5sums = 205c728191134d15cd5053e37c30a454
md5sums = 520350c4ab6aa1385f75028d22e769be
- md5sums = bd4927170182ea7c8dcf367fda7a0f5c
- md5sums = 86af94ebce3f2d5a40e3a01fb1e1b0bc
- md5sums = 0987c858a20d66760bb2627d9517eb8d
- md5sums = e17a8796e00b951ba2fcd7b53356a73c
+ md5sums = 70411ddfa47c969132274d49383f7f19
+ md5sums = 17774ac560e38ffb94bb95abd91bc5f4
+ md5sums = b2ebed4874f2f96fdcf002bf297e8f58
+ md5sums = 582e9105abc065e41b8edf976799de78
pkgname = geomspace
diff --git a/PKGBUILD b/PKGBUILD
index 2eda075d41b6..a168e5e469be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,47 @@
# Maintainer: Michael Kogan <michael dot kogan at gmx dot net>
pkgname=geomspace
-pkgver=0.13.1
+pkgver=0.14
pkgrel=1
pkgdesc="A browser for geometric (i.e. Euclidean, Riemann, Minkowski) spaces"
arch=('i686' 'x86_64')
url="https://sourceforge.net/projects/geomspace/"
license=('GPL')
depends=('libxpm' 'mesa' 'fltk')
-source=(http://downloads.sourceforge.net/project/$pkgname/0.13/GeomSpace-$pkgver-src.tar.gz \
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgver/GeomSpace-$pkgver-src.tar.gz \
http://downloads.sourceforge.net/project/$pkgname/Theory/UniformGeomSpace-2010.11.02-en.pdf \
- http://sourceforge.net/projects/geomspace/files/Models/5Cubes.gmsp
- http://sourceforge.net/projects/geomspace/files/Models/5Tetra.gmsp
+ http://sourceforge.net/projects/geomspace/files/Models/5Cubes.gmsp \
+ http://sourceforge.net/projects/geomspace/files/Models/5Tetra.gmsp \
make.patch \
- geomspace.png \
- geomspace.desktop \
- linux.mk)
-md5sums=('822c6732db58fd844413fa001ef690fb'
+ x11.patch\
+ deps.patch\
+ desktop.patch)
+md5sums=('00107ea0f443c1b9f800876b3b5d1342'
'14560f6f2cba975be1ba8d047b5acec5'
'205c728191134d15cd5053e37c30a454'
'520350c4ab6aa1385f75028d22e769be'
- 'bd4927170182ea7c8dcf367fda7a0f5c'
- '86af94ebce3f2d5a40e3a01fb1e1b0bc'
- '0987c858a20d66760bb2627d9517eb8d'
- 'e17a8796e00b951ba2fcd7b53356a73c')
+ '70411ddfa47c969132274d49383f7f19'
+ '17774ac560e38ffb94bb95abd91bc5f4'
+ 'b2ebed4874f2f96fdcf002bf297e8f58'
+ '582e9105abc065e41b8edf976799de78')
_pkgname=GeomSpace
build() {
- cp linux.mk $srcdir/GeomSpace/make
cd $srcdir/GeomSpace/make
patch Makefile < $srcdir/make.patch
- echo "OS = linux" > platform
+ patch x11.mk < $srcdir/x11.patch
+ patch deps < $srcdir/deps.patch
+ echo "OS = linux" >> platform
make || return 1
+ cd $srcdir/GeomSpace/bin
+ patch GeomSpace.desktop < $srcdir/desktop.patch
}
package() {
- install -D -m755 $srcdir/GeomSpace/bin/geomspace $pkgdir/usr/bin/geomspace
+ install -D -m755 $srcdir/GeomSpace/bin/GeomSpace $pkgdir/usr/bin/geomspace
install -D -m644 $srcdir/GeomSpace/doc/DeveloperManual-en.pdf $pkgdir/usr/share/doc/$pkgname/DeveloperManual-en.pdf
install -D -m644 $srcdir/GeomSpace/doc/UserManual-en.pdf $pkgdir/usr/share/doc/$pkgname/UserManual-en.pdf
install -D -m644 $srcdir/UniformGeomSpace-2010.11.02-en.pdf $pkgdir/usr/share/doc/$pkgname/UniformGeomSpace-2010.11.02-en.pdf
- install -D -m644 ../${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
- install -D -m644 ../${pkgname}.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
+ install -D -m644 $srcdir/GeomSpace/bin/${_pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+ install -D -m644 $srcdir/GeomSpace/bin/icn/${_pkgname}.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
install -d -m755 ${pkgdir}/usr/share/${_pkgname}
install -d -m755 ${pkgdir}/usr/share/${_pkgname}/models
install -d -m755 ${pkgdir}/usr/share/${_pkgname}/i18n
diff --git a/deps.patch b/deps.patch
new file mode 100644
index 000000000000..1d80f623e960
--- /dev/null
+++ b/deps.patch
@@ -0,0 +1,9 @@
+--- src/GeomSpace/make/deps 2016-06-11 17:25:08.000000000 +0200
++++ /home/photon/Desktop/GeomSpace/make/deps 2016-04-30 11:06:16.384909352 +0200
+@@ -1,5 +1,5 @@
+ FLTK = fltk-1.3.3
+-FLTK_DIR = $(BASEDIR)/../$(FLTK)/
++FLTK_DIR = /usr/bin/
+
+ DEPS = FLTK
+
diff --git a/desktop.patch b/desktop.patch
new file mode 100644
index 000000000000..b1322239dbca
--- /dev/null
+++ b/desktop.patch
@@ -0,0 +1,13 @@
+--- src/GeomSpace/bin/GeomSpace.desktop 2016-07-12 09:57:48.214925029 +0200
++++ src/GeomSpace/bin/GeomSpace_new.desktop 2016-07-12 10:00:01.335729107 +0200
+@@ -2,8 +2,8 @@
+ Type=Application
+ Name=GeomSpace
+ Comment=Interactive geometry software for Euclidean and non Euclidean homogeneous spaces
+-Exec=/usr/bin/GeomSpace
+-Icon=/usr/share/GeomSpace/icn/GeomSpace.png
++Exec=/usr/bin/geomspace
++Icon=/usr/share/pixmaps/geomspace.png
+ Terminal=false
+ Encoding=UTF-8
+ Categories=Application;Education;Science;Mathematics;Geometry
diff --git a/make.patch b/make.patch
index aa6736ee747b..0a17100f056c 100644
--- a/make.patch
+++ b/make.patch
@@ -1,16 +1,14 @@
---- Makefile 2012-01-19 20:33:02.000000000 +0100
-+++ Makefile_new 2012-01-31 23:03:49.022922219 +0100
-@@ -14,13 +14,11 @@
- all: compile build
+--- src/GeomSpace/make/Makefile 2016-06-11 17:25:08.000000000 +0200
++++ /home/photon/Desktop/Makefile_new 2016-07-11 12:28:47.876278173 +0200
+@@ -15,11 +15,9 @@
+ include $(OS).mk
clean:
- clear
- rm -R $(SRC)/*.o $(SRC)/algebra/*.o $(SRC)/geometry/*.o $(SRC)/graphics/*.o $(SRC)/io/*.o $(BIN)/*
-
- include $(OS).mk
+ rm -R $(SRC)/*.o $(BIN)/*
- compile:
+ prepare:
- clear
- @echo "Compile $(TARGET) version $(VERSION) ($(STATUS)) for $(OS) platform"
+ @echo "Compile $(APPNAME) version $(VERSION) ($(STATUS)) for $(OS) platform"
@echo "(If you want to change it, modify make/platform file)"
@echo ""
diff --git a/x11.patch b/x11.patch
new file mode 100644
index 000000000000..7c6be352d984
--- /dev/null
+++ b/x11.patch
@@ -0,0 +1,8 @@
+--- src/GeomSpace/make/x11.mk 2016-06-11 17:25:08.000000000 +0200
++++ /home/photon/Desktop/GeomSpace/make/x11.mk 2016-07-11 12:34:28.599783153 +0200
+@@ -1,4 +1,5 @@
+ CXXFLAGS += -DGMSP_X11
++LDSTATICFLAGS += -lX11 -lXpm -lGLU -lGL
+ SUFFIX =
+ PREFIX = /usr
+ SHARE_PATH = $(PREFIX)/share