summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892015-06-29 09:12:14 +0200
committerPhoton892015-06-29 09:12:14 +0200
commit96b99c9a974fd793f930d06ee3f8d9973857b910 (patch)
tree897f2646a99ae2d9d2e8f9dc5416400c0309572c
downloadaur-96b99c9a974fd793f930d06ee3f8d9973857b910.tar.gz
Initial import
-rw-r--r--.AURINFO22
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD53
-rw-r--r--geomspace.desktop9
-rw-r--r--geomspace.pngbin0 -> 6835 bytes
-rw-r--r--linux.mk8
-rw-r--r--make.patch16
7 files changed, 138 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..9f48664b8b21
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,22 @@
+pkgbase = geomspace
+ pkgdesc = A browser for geometric (i.e. Euclidean, Riemann, Minkowski) spaces
+ pkgver = 0.13
+ pkgrel = 1
+ url = https://sourceforge.net/projects/geomspace/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxpm
+ depends = mesa
+ depends = fltk
+ source = http://downloads.sourceforge.net/project/geomspace/0.13/GeomSpace-0.13-src.tar.gz
+ source = http://downloads.sourceforge.net/project/geomspace/Theory/UniformGeomSpace-2010.11.02-en.pdf
+ source = http://sourceforge.net/projects/geomspace/files/Models/5Cubes.gmsp
+ source = http://sourceforge.net/projects/geomspace/files/Models/5Tetra.gmsp
+ source = make.patch
+ source = geomspace.png
+ source = geomspace.desktop
+ source = linux.mk
+
+pkgname = geomspace
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39eb91c41341
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = geomspace
+ pkgdesc = A browser for geometric (i.e. Euclidean, Riemann, Minkowski) spaces
+ pkgver = 0.13
+ pkgrel = 1
+ url = https://sourceforge.net/projects/geomspace/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxpm
+ depends = mesa
+ depends = fltk
+ source = http://downloads.sourceforge.net/project/geomspace/0.13/GeomSpace-0.13-src.tar.gz
+ source = http://downloads.sourceforge.net/project/geomspace/Theory/UniformGeomSpace-2010.11.02-en.pdf
+ source = http://sourceforge.net/projects/geomspace/files/Models/5Cubes.gmsp
+ source = http://sourceforge.net/projects/geomspace/files/Models/5Tetra.gmsp
+ source = make.patch
+ source = geomspace.png
+ source = geomspace.desktop
+ source = linux.mk
+ md5sums = 4c709d41e1347de9b12024cd9fafb36d
+ md5sums = 14560f6f2cba975be1ba8d047b5acec5
+ md5sums = 205c728191134d15cd5053e37c30a454
+ md5sums = 520350c4ab6aa1385f75028d22e769be
+ md5sums = bd4927170182ea7c8dcf367fda7a0f5c
+ md5sums = 86af94ebce3f2d5a40e3a01fb1e1b0bc
+ md5sums = 0987c858a20d66760bb2627d9517eb8d
+ md5sums = e17a8796e00b951ba2fcd7b53356a73c
+
+pkgname = geomspace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e0b70a3f745
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Michael Kogan <michael dot kogan at gmx dot net>
+
+pkgname=geomspace
+pkgver=0.13
+pkgrel=1
+pkgdesc="A browser for geometric (i.e. Euclidean, Riemann, Minkowski) spaces"
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/geomspace/"
+license=('GPL')
+depends=('libxpm' 'mesa' 'fltk')
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgver/GeomSpace-$pkgver-src.tar.gz \
+ http://downloads.sourceforge.net/project/$pkgname/Theory/UniformGeomSpace-2010.11.02-en.pdf \
+ http://sourceforge.net/projects/geomspace/files/Models/5Cubes.gmsp
+ http://sourceforge.net/projects/geomspace/files/Models/5Tetra.gmsp
+ make.patch \
+ geomspace.png \
+ geomspace.desktop \
+ linux.mk)
+md5sums=('4c709d41e1347de9b12024cd9fafb36d'
+ '14560f6f2cba975be1ba8d047b5acec5'
+ '205c728191134d15cd5053e37c30a454'
+ '520350c4ab6aa1385f75028d22e769be'
+ 'bd4927170182ea7c8dcf367fda7a0f5c'
+ '86af94ebce3f2d5a40e3a01fb1e1b0bc'
+ '0987c858a20d66760bb2627d9517eb8d'
+ 'e17a8796e00b951ba2fcd7b53356a73c')
+_pkgname=GeomSpace
+build() {
+ cp linux.mk $srcdir/GeomSpace/make
+ cd $srcdir/GeomSpace/make
+ patch Makefile < $srcdir/make.patch
+ echo "OS = linux" > platform
+ make || return 1
+}
+package() {
+ install -D -m755 $srcdir/GeomSpace/bin/geomspace $pkgdir/usr/bin/geomspace
+ install -D -m644 $srcdir/GeomSpace/doc/DeveloperManual-en.pdf $pkgdir/usr/share/doc/$pkgname/DeveloperManual-en.pdf
+ install -D -m644 $srcdir/GeomSpace/doc/UserManual-en.pdf $pkgdir/usr/share/doc/$pkgname/UserManual-en.pdf
+ install -D -m644 $srcdir/UniformGeomSpace-2010.11.02-en.pdf $pkgdir/usr/share/doc/$pkgname/UniformGeomSpace-2010.11.02-en.pdf
+ install -D -m644 ../${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+ install -D -m644 ../${pkgname}.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
+ install -d -m755 ${pkgdir}/usr/share/${_pkgname}
+ install -d -m755 ${pkgdir}/usr/share/${_pkgname}/models
+ install -d -m755 ${pkgdir}/usr/share/${_pkgname}/i18n
+ install -D -m644 ../5Cubes.gmsp ${pkgdir}/usr/share/${_pkgname}/models
+ install -D -m644 ../5Tetra.gmsp ${pkgdir}/usr/share/${_pkgname}/models
+ install -D -m644 $srcdir/GeomSpace/bin/i18n/C ${pkgdir}/usr/share/${_pkgname}/i18n
+ install -D -m644 $srcdir/GeomSpace/bin/i18n/de ${pkgdir}/usr/share/${_pkgname}/i18n
+ install -D -m644 $srcdir/GeomSpace/bin/i18n/ro ${pkgdir}/usr/share/${_pkgname}/i18n
+ install -D -m644 $srcdir/GeomSpace/bin/i18n/ru ${pkgdir}/usr/share/${_pkgname}/i18n
+ msg "\033[31;1m The user manual and a document containing a theory explanation have been installed to /usr/share/doc/$pkgname. It is strongly recommended to read them in order to use Geomspace! \033[0m"
+ msg "\033[31;1m Some models of geometrical objects have been installed to /usr/share/$pkgname/models. Additional models can be found at http://sourceforge.net/projects/geomspace/files/Models/ \033[0m"
+}
diff --git a/geomspace.desktop b/geomspace.desktop
new file mode 100644
index 000000000000..f39f6ef35aca
--- /dev/null
+++ b/geomspace.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Geomspace
+Comment=A browser for geometric (i.e. Euclidean, Riemann, Minkowski) spaces
+Exec=/usr/bin/geomspace
+Icon=geomspace.png
+Terminal=false
+Type=Application
+Encoding=UTF-8
+Categories=Application;Science; \ No newline at end of file
diff --git a/geomspace.png b/geomspace.png
new file mode 100644
index 000000000000..79995b074e66
--- /dev/null
+++ b/geomspace.png
Binary files differ
diff --git a/linux.mk b/linux.mk
new file mode 100644
index 000000000000..80a7163a16bf
--- /dev/null
+++ b/linux.mk
@@ -0,0 +1,8 @@
+CXX = g++
+CXXFLAGS = -Os -Wall -Wunused -Wno-format-y2k -fno-exceptions -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_THREAD_SAFE -D_REENTRANT -DGMSP_X11
+LDSTATICFLAGS = /usr/lib/libfltk_gl.so -lGLU -lGL /usr/lib/libfltk_images.so -lpng -lz -ljpeg /usr/lib/libfltk.so -lXext -lpthread -ldl -lm -lX11 -lXpm -lXft -lfontconfig -lXinerama
+SUFFIX =
+TARGET = geomspace
+prebuild:
+
+postbuild:
diff --git a/make.patch b/make.patch
new file mode 100644
index 000000000000..aa6736ee747b
--- /dev/null
+++ b/make.patch
@@ -0,0 +1,16 @@
+--- Makefile 2012-01-19 20:33:02.000000000 +0100
++++ Makefile_new 2012-01-31 23:03:49.022922219 +0100
+@@ -14,13 +14,11 @@
+ all: compile build
+
+ clean:
+- clear
+ rm -R $(SRC)/*.o $(SRC)/algebra/*.o $(SRC)/geometry/*.o $(SRC)/graphics/*.o $(SRC)/io/*.o $(BIN)/*
+
+ include $(OS).mk
+
+ compile:
+- clear
+ @echo "Compile $(TARGET) version $(VERSION) ($(STATUS)) for $(OS) platform"
+ @echo "(If you want to change it, modify make/platform file)"
+ @echo ""