summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrés J. Díaz2022-06-24 12:12:30 +0200
committerAndrés J. Díaz2022-06-24 12:12:30 +0200
commit51eadaaf92ee2f641a8d3946efae21e96ac18700 (patch)
treef37cae395fc69f377c7e427146de7509070f3a9d
parenta5ec443c04079c546c9d0cc57ec82c90b973ae38 (diff)
downloadaur-51eadaaf92ee2f641a8d3946efae21e96ac18700.tar.gz
upgpkg: geomyidae 0.50.1-1
upstream release bump(geomyidae): v0.50.1 Signed-off-by: Andrés J. Díaz <ajdiaz@ajdiaz.me>
-rw-r--r--.SRCINFO7
-rw-r--r--LICENSE26
-rw-r--r--PKGBUILD14
3 files changed, 37 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76db75c88102..687af71e5bd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = geomyidae
pkgdesc = Small C-based gopherd
- pkgver = 0.34
+ pkgver = 0.50.1
pkgrel = 1
url = https://gopher.floodgap.com/gopher/gw?gopher://bitreich.org:70/1/scm/geomyidae/file/README.gph
arch = x86_64
license = MIT
backup = var/gopher/CGI
backup = var/gopher/index.gph
- source = ftp://bitreich.org/releases/geomyidae/geomyidae-v0.34.tgz
- sha256sums = 2580ad0f229cd3f5c33495975a708679aeaf5276c06ec8d55871d7f69b216eb0
+ source = ftp://bitreich.org/releases/geomyidae/geomyidae-v0.50.1.tar.lz
+ sha512sums = ecfed96cd456ff0bafb09527abdf4d50183331f9b4462cdfc37cdcb1274dd72aa9304da2d962670a37503500b27713fd24a179691aa5d6a613776cf452319f24
pkgname = geomyidae
-
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b5b05891336d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,26 @@
+MIT/X Consortium License
+
+© 2006-2019 Christoph Lohmann <20h@r-36.net>
+© 2015-2017 Hiltjo Posthuma <hiltjo@codemadness.org>
+© 2007 Jeff Woodall <jgw@freeshell.org>
+© 2008 J. A. Neitzel <jan@v6shell.org>
+© 2010-2011 James Penketh <tamber@furryhelix.co.uk>
+© 2019 Brett Hogan <tiwesdaeg@lignumvitae.org>
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index dac45d7ff36a..6d64090b24bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Andrés J. Díaz <ajdiaz@ajdiaz.me>
pkgname=geomyidae
-pkgver=0.34
+pkgver=0.50.1
pkgrel=1
pkgdesc='Small C-based gopherd'
arch=('x86_64')
@@ -9,8 +9,10 @@ url='https://gopher.floodgap.com/gopher/gw?gopher://bitreich.org:70/1/scm/geomyi
license=('MIT')
backup=('var/gopher/CGI'
'var/gopher/index.gph')
-source=("ftp://bitreich.org/releases/${pkgname}/${pkgname}-v${pkgver}.tgz")
-sha256sums=('2580ad0f229cd3f5c33495975a708679aeaf5276c06ec8d55871d7f69b216eb0')
+source=("ftp://bitreich.org/releases/${pkgname}/${pkgname}-v${pkgver}.tar.lz")
+sha512sums=(
+ 'ecfed96cd456ff0bafb09527abdf4d50183331f9b4462cdfc37cdcb1274dd72aa9304da2d962670a37503500b27713fd24a179691aa5d6a613776cf452319f24'
+)
build() {
make -C "${pkgname}-v${pkgver}"
@@ -19,10 +21,10 @@ build() {
package() {
cd "${pkgname}-v${pkgver}"
make DESTDIR="${pkgdir}" PREFIX="/usr" install
- install -Dm644 -t "${pkgdir}/var/gopher" {CGI,index.gph}
+ install -Dm644 -t "${pkgdir}/var/gopher" index.gph
install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" {LINKS,README}
install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}/rc.d" 'rc.d/'*
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${startdir}/LICENSE"
}
# vim: ts=2 sw=2 et: