summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-05-27 10:36:49 -0600
committerMark Wagie2023-05-27 10:36:49 -0600
commite5fa14314a53963ae22666737ffd7735b6fb927c (patch)
treef176831c1c7254a0e89a712ce8e4049d3ee622b9
parentf582bc68a05bfc1fc8ffcc097247cf498e2ac846 (diff)
downloadaur-e5fa14314a53963ae22666737ffd7735b6fb927c.tar.gz
add PR 74: Link handling
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19548ace2224..2e3602c63061 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = geopard
pkgdesc = Colorful, adaptive gemini browser
pkgver = 1.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://ranfdev.com/projects/Geopard
arch = x86_64
arch = aarch64
@@ -13,6 +13,8 @@ pkgbase = geopard
makedepends = meson
depends = libadwaita
source = git+https://github.com/ranfdev/Geopard.git#commit=9f9abcdd5d117ff808eb5d4cc22e06fd210c9d2c
+ source = https://github.com/ranfdev/Geopard/pull/74.patch
sha256sums = SKIP
+ sha256sums = ff8ae33144906e844d5b80bdb9865d4bdc4387dc44d9e0ab0ef34a26d1a1fbf5
pkgname = geopard
diff --git a/PKGBUILD b/PKGBUILD
index c1ce5f14477d..b82a1ee89aaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=geopard
pkgver=1.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Colorful, adaptive gemini browser"
arch=('x86_64' 'aarch64')
url="https://ranfdev.com/projects/Geopard"
@@ -10,8 +10,10 @@ depends=('libadwaita')
makedepends=('blueprint-compiler' 'cargo' 'git' 'meson')
checkdepends=('appstream-glib')
_commit=9f9abcdd5d117ff808eb5d4cc22e06fd210c9d2c # tags/v1.4.0^0
-source=("git+https://github.com/ranfdev/Geopard.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("git+https://github.com/ranfdev/Geopard.git#commit=$_commit"
+ 'https://github.com/ranfdev/Geopard/pull/74.patch')
+sha256sums=('SKIP'
+ 'ff8ae33144906e844d5b80bdb9865d4bdc4387dc44d9e0ab0ef34a26d1a1fbf5')
pkgver() {
cd "$srcdir/Geopard"
@@ -20,6 +22,11 @@ pkgver() {
prepare() {
cd "$srcdir/Geopard"
+
+ # Link handling
+ # https://github.com/ranfdev/Geopard/issues/71
+ patch -Np1 -i ../74.patch
+
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
cargo fetch --target "$CARCH-unknown-linux-gnu"