summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-05-27 10:19:22 -0600
committerMark Wagie2023-05-27 10:19:22 -0600
commitf582bc68a05bfc1fc8ffcc097247cf498e2ac846 (patch)
tree9cd65aae916b69adc1a539a092625849478ebc39
parentdaee324412079446eb38d6b03857d8e6969f0265 (diff)
downloadaur-f582bc68a05bfc1fc8ffcc097247cf498e2ac846.tar.gz
use local cargo cache
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ab2698e8d63..c1ce5f14477d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,11 +20,13 @@ pkgver() {
prepare() {
cd "$srcdir/Geopard"
+ export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
cargo fetch --target "$CARCH-unknown-linux-gnu"
}
build() {
+ export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
arch-meson Geopard build
meson compile -C build