summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2019-08-19 11:29:13 +0300
committerChristoph Fink2019-08-19 11:29:13 +0300
commit9ea29e9bdc9ea3dd6dfb96e873adeba4abd89da4 (patch)
tree6b15fbbf07296cd7139228c955d01d31670e71d9
parentcf7a8909d2d38f3160f130faaf8759a56884e514 (diff)
downloadaur-9ea29e9bdc9ea3dd6dfb96e873adeba4abd89da4.tar.gz
version != tag
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09d347775880..7d9475d5d65c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = geos-git
pkgdesc = C++ port of the Java Topology Suite (git version)
- pkgver = 3.7.0rc1.r9.g1be02b36
+ pkgver = 3.8.0dev.4c70abae
pkgrel = 1
url = http://trac.osgeo.org/geos/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index a0df7bc55190..8811b914b9b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: peippo <christoph.fink@gmail.com>
pkgname=geos-git
-pkgver=3.7.0rc1.r9.g1be02b36
+pkgver=3.8.0dev.4c70abae
pkgrel=1
pkgdesc="C++ port of the Java Topology Suite (git version)"
@@ -16,18 +16,24 @@ source=("${pkgname}::git+https://git.osgeo.org/gitea/geos/geos.git")
md5sums=('SKIP')
pkgver() {
- cd "${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname}"
+ if [[ -e "Version.txt" ]]; then
+ source Version.txt
+ COMMIT="$(git rev-parse --short HEAD)"
+ echo "${GEOS_VERSION_MAJOR}.${GEOS_VERSION_MINOR}.${GEOS_VERSION_PATCH}${GEOS_PATCH_WORD}.${COMMIT}"
+ else
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ fi
}
build() {
- cd "${pkgname}"
- ./autogen.sh
- ./configure --prefix=/usr
- make
+ cd "${pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "${pkgname}"
- make DESTDIR="${pkgdir}" install
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
}