summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2018-08-28 11:20:33 +0300
committerChristoph Fink2018-08-28 11:20:33 +0300
commitcf7a8909d2d38f3160f130faaf8759a56884e514 (patch)
treef1d9131e62de20a57778040443a846ce6d1ce226
downloadaur-cf7a8909d2d38f3160f130faaf8759a56884e514.tar.gz
geos-git 3.7.0rc1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09d347775880
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = geos-git
+ pkgdesc = C++ port of the Java Topology Suite (git version)
+ pkgver = 3.7.0rc1.r9.g1be02b36
+ pkgrel = 1
+ url = http://trac.osgeo.org/geos/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = gcc-libs
+ depends = bash
+ provides = geos
+ conflicts = geos
+ source = geos-git::git+https://git.osgeo.org/gitea/geos/geos.git
+ md5sums = SKIP
+
+pkgname = geos-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0df7bc55190
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: peippo <christoph.fink@gmail.com>
+pkgname=geos-git
+pkgver=3.7.0rc1.r9.g1be02b36
+pkgrel=1
+
+pkgdesc="C++ port of the Java Topology Suite (git version)"
+url="http://trac.osgeo.org/geos/"
+license=('LGPL')
+
+arch=('i686' 'x86_64')
+depends=('gcc-libs' 'bash')
+conflicts=('geos')
+provides=('geos')
+
+source=("${pkgname}::git+https://git.osgeo.org/gitea/geos/geos.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}