summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo2015-08-08 15:57:16 +0200
committerDanilo2015-08-08 15:57:16 +0200
commitbd92347e86a45e6e9785252a538ba97c76a9d1db (patch)
treec40a8b3acad237af3e06bfe96b602dcd5723dc8a
downloadaur-bd92347e86a45e6e9785252a538ba97c76a9d1db.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD26
-rw-r--r--geotag2
-rw-r--r--geotag.desktop8
5 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9965a4989695
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = geotag
+ pkgdesc = Geotag is an open source program that allows you match date/time information from photos with location information from a GPS unit or from a map
+ pkgver = 0.096
+ pkgrel = 1
+ url = http://geotag.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = java-runtime
+ depends = perl-exiftool
+ source = http://downloads.sourceforge.net/project/geotag/geotag/0.096/geotag-0.096.jar
+ source = geotag.desktop
+ source = geotag
+ sha256sums = 3bfe5474e1d89d442a1386ccdd107ce3c2c818c1f231cc3e0b14898121274299
+ sha256sums = 03e25f98f958a205fed56657e21c30f636b8f67bc0f5e41f88d6bf3bfa1fb3fe
+ sha256sums = dd836097b81d0d4fea801ef4211d2e60befe6067e8ae3d29263bebcf268590bd
+
+pkgname = geotag
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d392f0e82c4a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.jar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afd4b2e34165
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Original Author: Johannes Wienke <languitar at semipol dot de>
+# Maintainer: Danilo Bargen <aur at dbrgn dot ch>
+
+pkgname=geotag
+pkgver=0.096
+pkgrel=1
+pkgdesc="Geotag is an open source program that allows you match date/time information from photos with location information from a GPS unit or from a map"
+arch=('i686' 'x86_64')
+url="http://geotag.sourceforge.net/"
+license=('GPL2')
+depends=('java-runtime' 'perl-exiftool')
+source=(http://downloads.sourceforge.net/project/geotag/geotag/$pkgver/geotag-$pkgver.jar
+ $pkgname.desktop
+ $pkgname)
+sha256sums=('3bfe5474e1d89d442a1386ccdd107ce3c2c818c1f231cc3e0b14898121274299'
+ '03e25f98f958a205fed56657e21c30f636b8f67bc0f5e41f88d6bf3bfa1fb3fe'
+ 'dd836097b81d0d4fea801ef4211d2e60befe6067e8ae3d29263bebcf268590bd')
+
+package() {
+ cd $srcdir
+
+ install -D -m644 $pkgname-$pkgver.jar $pkgdir/usr/share/java/$pkgname/$pkgname.jar || return 1
+ install -D -m644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop || return 1
+ install -D -m755 $srcdir/$pkgname $pkgdir/usr/bin/$pkgname || return 1
+ install -D -m644 $srcdir/images/$pkgname-128.png $pkgdir/usr/share/pixmaps/$pkgname.png || return 1
+}
diff --git a/geotag b/geotag
new file mode 100644
index 000000000000..29b48d2f3121
--- /dev/null
+++ b/geotag
@@ -0,0 +1,2 @@
+#!/bin/bash
+PATH=/usr/bin/perlbin/vendor/:$PATH java -jar /usr/share/java/geotag/geotag.jar
diff --git a/geotag.desktop b/geotag.desktop
new file mode 100644
index 000000000000..684029631114
--- /dev/null
+++ b/geotag.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Geotag
+Comment=Program to match date/time information from photos with location information from a GPS unit
+Exec=geotag
+Icon=geotag.png
+Terminal=false
+Type=Application
+Categories=Application;Graphics;