summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit790708e4404d73de111ff070489fcc59e95f01f6 (patch)
treef85816bd40a126530b3cd5429d7822fdff042958
downloadaur-790708e4404d73de111ff070489fcc59e95f01f6.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
3 files changed, 56 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..8c24f88db2ec
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = geotoad
+ pkgdesc = A tool to simplify geocaching
+ pkgver = 3.22.0
+ pkgrel = 1
+ url = http://geotoad.googlecode.com/
+ arch = any
+ license = custom
+ depends = ruby
+ source = http://geotoad.googlecode.com/svn/branches/downloads/files/geotoad-3.22.0.tar.gz
+ sha256sums = a190dbdf07b71ac27de2b6c3ff57325dead5ccc9e4dd6bc9baa169671ef6efaf
+
+pkgname = geotoad
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c24f88db2ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = geotoad
+ pkgdesc = A tool to simplify geocaching
+ pkgver = 3.22.0
+ pkgrel = 1
+ url = http://geotoad.googlecode.com/
+ arch = any
+ license = custom
+ depends = ruby
+ source = http://geotoad.googlecode.com/svn/branches/downloads/files/geotoad-3.22.0.tar.gz
+ sha256sums = a190dbdf07b71ac27de2b6c3ff57325dead5ccc9e4dd6bc9baa169671ef6efaf
+
+pkgname = geotoad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28dfcd5a5601
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=geotoad
+pkgver=3.22.0
+pkgrel=1
+pkgdesc="A tool to simplify geocaching"
+arch=('any')
+url="http://geotoad.googlecode.com/"
+license=('custom')
+depends=('ruby')
+source=(http://geotoad.googlecode.com/svn/branches/downloads/files/$pkgname-$pkgver.tar.gz)
+sha256sums=('a190dbdf07b71ac27de2b6c3ff57325dead5ccc9e4dd6bc9baa169671ef6efaf')
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+
+ install -d "${pkgdir}"/usr/{bin,share/${pkgname}}
+ cp -R * "${pkgdir}"/usr/share/${pkgname}
+
+ echo -e "#!/bin/bash\n\n/usr/share/${pkgname}/geotoad.rb" > "${pkgdir}"/usr/bin/${pkgname}
+ chmod 755 "${pkgdir}"/usr/bin/${pkgname}
+
+#license and man file
+ install -D -m644 COPYRIGHT.txt "${pkgdir}"/usr/share/licenses/${pkgname}/COPYRIGHT.txt
+ install -D -m644 $pkgname.1 "${pkgdir}"/usr/share/man/man1/$pkgname.1
+
+#removing Debian specific files
+ rm -rf "${pkgdir}"/usr/share/$pkgname/debian
+}