summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2022-12-08 04:22:08 +0800
committerlilac2022-12-08 04:22:08 +0800
commitae70ab84c08ff5971e31ffb0acf7326390dc86d3 (patch)
treedec4772f2dda2f81f1da6d7f13827e8bb1f91273
parent8d0f06e4871aafba892fc560133687ca9db163dc (diff)
downloadaur-ae70ab84c08ff5971e31ffb0acf7326390dc86d3.tar.gz
[lilac] updated to 4.6.6-2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
-rw-r--r--geph4-client.default56
-rw-r--r--geph4-client.service2
4 files changed, 46 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a57240320dfb..7102a59cafc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = geph4-client
pkgdesc = A command-line Geph4 toolset
- pkgver = 4.5.2.alpha.2
- pkgrel = 1
+ pkgver = 4.6.6
+ pkgrel = 2
url = https://github.com/geph-official/geph4
arch = x86_64
groups = geph4
@@ -9,12 +9,13 @@ pkgbase = geph4-client
makedepends = rust
depends = gcc-libs
conflicts = geph4-client-git
+ options = !lto
backup = etc/default/geph4-client
source = geph4-client.default
source = geph4-client.service
- source = geph4-client-4.5.2.alpha.2.tar.gz::https://github.com/geph-official/geph4/archive/v4.5.2-alpha.2.tar.gz
- sha256sums = fe10aa9e8ecc58e3b01487cb60c6fe970dd80343d1b715744e734077b1e14f66
- sha256sums = 2aef927e466ce22796bbaec6d618f6178d0251e6d0ba1df3c526d3374dd903da
- sha256sums = a5e1765549c7f25d2578d05de302fcf6bcddc375863433ad315d1cc2ce15db42
+ source = geph4-client-4.6.6.tar.gz::https://github.com/geph-official/geph4/archive/v4.6.6.tar.gz
+ sha256sums = 4e6ac4d3e31d7bf0fd4cb4b9269bbb124501a07a4701ce9728e857751773e4dd
+ sha256sums = e3d7e3afb1b524e93e60a80a21773a16de17643865bdf6a1a1f2e17fc2cc8e2d
+ sha256sums = a10582bdc20b72054877d65aa5a30d0702a63a6362f60edd4960c9be5dc3f7d3
pkgname = geph4-client
diff --git a/PKGBUILD b/PKGBUILD
index 8934a0281c5e..825a7c3857ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Dct Mei <dctxmei@yandex.com>
pkgname=geph4-client
-pkgver=4.5.2.alpha.2
-pkgrel=1
+pkgver=4.6.6
+pkgrel=2
pkgdesc="A command-line Geph4 toolset"
arch=('x86_64')
url="https://github.com/geph-official/geph4"
@@ -12,11 +12,12 @@ depends=('gcc-libs')
makedepends=('rust')
conflicts=('geph4-client-git')
backup=('etc/default/geph4-client')
+options=('!lto')
source=("geph4-client.default"
"geph4-client.service")
-sha256sums=('fe10aa9e8ecc58e3b01487cb60c6fe970dd80343d1b715744e734077b1e14f66'
- '2aef927e466ce22796bbaec6d618f6178d0251e6d0ba1df3c526d3374dd903da'
- 'a5e1765549c7f25d2578d05de302fcf6bcddc375863433ad315d1cc2ce15db42')
+sha256sums=('4e6ac4d3e31d7bf0fd4cb4b9269bbb124501a07a4701ce9728e857751773e4dd'
+ 'e3d7e3afb1b524e93e60a80a21773a16de17643865bdf6a1a1f2e17fc2cc8e2d'
+ 'a10582bdc20b72054877d65aa5a30d0702a63a6362f60edd4960c9be5dc3f7d3')
_prepare() {
if [[ "${pkgver}" =~ '.alpha' ]]; then
@@ -29,18 +30,21 @@ _prepare() {
_beta="${pkgver#*.beta}"
source+=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${_pkgver}-beta${_beta}.tar.gz")
_pkgver="${_pkgver}-beta${_beta}"
+ else
+ source+=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+ _pkgver="${pkgver}"
fi
}
_prepare
build() {
- cd "${srcdir}"/"${groups}-${_pkgver}"/
+ cd "${srcdir}"/"${pkgname}-${_pkgver}"/
cargo build --release --manifest-path=Cargo.toml
}
package() {
- cd "${srcdir}"/"${groups}-${_pkgver}"/
+ cd "${srcdir}"/"${pkgname}-${_pkgver}"/
install -Dm 644 LICENSE.md "${pkgdir}"/usr/share/licenses/geph4-client/LICENSE
install -Dm 755 target/release/geph4-client -t "${pkgdir}"/usr/bin/
install -Dm 644 "${srcdir}"/geph4-client.default "${pkgdir}"/etc/default/geph4-client
diff --git a/geph4-client.default b/geph4-client.default
index d9f7d0979c87..544c56a95309 100644
--- a/geph4-client.default
+++ b/geph4-client.default
@@ -1,46 +1,44 @@
# The default settings for Geph4 client Service
# Fill in the subcommand here, you can run
-# `geph4-client -h` to view:
-# binder-proxy | connect | sync
+# `geph4-client --help` to view:
+# binder-proxy | bridge-test | connect | sync
SUBCOMMAND=connect
+
# Fill in some flags here, you can run
-# `geph4-client connect -h` to view:
-# --stdio-vpn: whether or not to wait for VPN commands on stdio
-# --use-bridges: whether or not to use bridges
+# `geph4-client connect --help` to view:
+#
+# --exclude-prc: Whether or not to exclude PRC domains
+# --stdio-vpn: Whether or not to wait for VPN commands on stdio
+# --sticky-bridges: Whether or not to stick to the same set of bridges
+# --use-bridges: Whether or not to use bridges
+# --use-tcp: Whether or not to force TCP mode
+#
FLAGS="--use-bridges"
+
# Fill in some options here, you can run
-# `geph4-client connect -h` to view:
+#
+# `geph4-client connect --help` to view:
+#
# --credential-cache:
# /var/cache/geph4-client/
+#
# --dns-listen:
-# where to listen for proxied DNS requests
-# --exit-server:
-# ca-mtl-01.exits.geph.io
-# fi-hel-01.exits.geph.io
-# sg-sgp-02.exits.geph.io
-# sosistab-jp-test.labooyah.be
-# tw-rmq-01.exits.geph.io
-# us-hio-01.exits.geph.io (default)
+# Where to listen for proxied DNS requests [default: 127.0.0.1:15353]
+#
# --http-listen:
-# where to listen for HTTP proxy connections (default: 127.0.0.1:9910)
-# --nettest-name:
-# a name for this test instance
-# --nettest-server:
-# an endpoint to send test results
+# Where to listen for HTTP proxy connections [default: 127.0.0.1:9910]
+#
# --socks5-listen:
-# where to listen for SOCKS5 connections (default: 127.0.0.1:9909)
+# Where to listen for SOCKS5 connections [default: 127.0.0.1:9909]
+#
# --stats-listen:
-# where to listen for REST-based local connections (default: 127.0.0.1:9809)
-OPTIONS="--exit-server us-hio-01.exits.geph.io"
+# Where to listen for REST-based local connections [default: 127.0.0.1:9809]
+#
+OPTIONS=""
+#
# Please enter the password you want to use:
PASSWORD=password
# Please enter the username you want to use:
USERNAME=username
-
-# geph4-vpn-helper
-VPN_SUBCOMMAND=connect
-VPN_FLAGS="--stdio-vpn --use-bridges"
-VPN_OPTIONS="--dns-listen 127.0.0.1:15353 --exit-server us-hio-01.exits.geph.io"
-VPN_PASSWORD=password
-VPN_USERNAME=username
+#
diff --git a/geph4-client.service b/geph4-client.service
index 2145097434c2..2879763fbdea 100644
--- a/geph4-client.service
+++ b/geph4-client.service
@@ -10,7 +10,7 @@ AmbientCapabilities=CAP_NET_BIND_SERVICE
NoNewPrivileges=true
EnvironmentFile=/etc/default/geph4-client
ExecStart=/usr/bin/geph4-client $SUBCOMMAND $FLAGS $OPTIONS --credential-cache /var/cache/geph4-client/ --password $PASSWORD --username $USERNAME
-Restart=on-abort
+Restart=on-failure
[Install]
WantedBy=multi-user.target