summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Valentini2015-07-27 09:53:16 +0200
committerRoberto Valentini2015-07-27 09:53:16 +0200
commit3b7f43bd569adf5ef42083e257142184dc91fd9e (patch)
treee88892f816f0bbb5e79694eb188918fb1749b585
downloadaur-3b7f43bd569adf5ef42083e257142184dc91fd9e.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--geppetto.desktop10
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6cf9e5c2251
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = geppetto
+ pkgdesc = Eclipse customized version for Puppet
+ pkgver = 4.3.1
+ pkgrel = 1
+ url = http://puppetlabs.github.io/geppetto/index.html
+ arch = x86_64
+ license = Apache
+ license = EPL
+ options = !strip
+ source = https://downloads.puppetlabs.com/geppetto/4.x/geppetto-linux.gtk.x86_64-4.3.1-R201501182354.zip
+ source = geppetto.desktop
+ md5sums = 853986a1b86c880008cb46f469b5f48d
+ md5sums = 5f70f7436790c399b192a01fea3cc29e
+
+pkgname = geppetto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c3d54003f72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Roberto Valentini <valantin89[at]gmail[dot]com>
+pkgname=geppetto
+pkgver=4.3.1
+_pkgrev=R201501182354
+pkgrel=1
+arch=('x86_64')
+pkgdesc="Eclipse customized version for Puppet"
+url="http://puppetlabs.github.io/geppetto/index.html"
+source=("https://downloads.puppetlabs.com/geppetto/4.x/geppetto-linux.gtk.${arch}-${pkgver}-${_pkgrev}.zip"
+ "geppetto.desktop")
+license=("Apache" "EPL")
+options=('!strip')
+md5sums=('853986a1b86c880008cb46f469b5f48d'
+ '5f70f7436790c399b192a01fea3cc29e')
+
+package() {
+ cd ${srcdir}
+
+ mkdir -p ${pkgdir}/opt
+ mkdir -p ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/usr/share/applications
+ mkdir -p ${pkgdir}/usr/share/pixmaps
+
+ cp -rf . ${pkgdir}/opt
+ ln -s ${pkgdir}/opt/${pkgname}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+
+ install -m 0644 geppetto.desktop "${pkgdir}/usr/share/applications/"
+ install -Dm 0644 ${srcdir}/${pkgname}/icon.xpm "${pkgdir}/usr/share/pixmaps/geppetto.xpm"
+}
diff --git a/geppetto.desktop b/geppetto.desktop
new file mode 100644
index 000000000000..0f5653182a6d
--- /dev/null
+++ b/geppetto.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Geppetto
+Comment=Geppetto a puppet IDE
+Keywords=geppetto;puppet;
+Exec=geppetto
+Icon=geppetto
+Terminal=false
+Type=Application
+Categories=Editor;
+StartupNotify=true