summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Alexander2016-04-01 12:07:09 -0700
committerJacob Alexander2016-04-01 12:24:24 -0700
commit70b29a058de8255c9693178f1b95abfbc1422870 (patch)
tree7efde073a1b6a4aefad2dc8727503bf82184ace3
downloadaur-70b29a058de8255c9693178f1b95abfbc1422870.tar.gz
Initial PKGBUILD for germinate, python-germinate and python2-germinate
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD73
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed4aff3f7e15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = germinate
+ pkgdesc = Takes lists of seed packages and expands their dependencies to produce a full list of packages. This can be used for purposes such as managing the list of packages present in a derived distribution's archive or CD builds.
+ pkgver = 2.23
+ pkgrel = 1
+ url = https://tracker.debian.org/pkg/germinate
+ arch = any
+ license = GPL
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python-apt
+ makedepends = python2-apt
+ options = !emptydirs
+ source = https://mirrors.ocf.berkeley.edu/debian/pool/main/g/germinate/germinate_2.23.tar.xz
+ sha256sums = aeadbd250ef4c065cc9aa0b0a7410ddee49b5c4aa31209c4f66d23652da612eb
+
+pkgname = germinate
+ depends =
+ depends = perl
+ depends = python
+
+pkgname = python-germinate
+ depends =
+ depends = germinate
+ depends = python
+
+pkgname = python2-germinate
+ depends =
+ depends = germinate
+ depends = python2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33f95406ccc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Jacob Alexander <haata at kiibohd com>
+pkgname=('germinate' 'python-germinate' 'python2-germinate')
+_pkgname=${pkgname[0]}
+pkgver=2.23
+pkgrel=1
+pkgdesc="Takes lists of seed packages and expands their dependencies to produce a full list of packages. This can be used for purposes such as managing the list of packages present in a derived distribution's archive or CD builds."
+arch=('any')
+url="https://tracker.debian.org/pkg/germinate"
+license=('GPL')
+makedepends=('python' 'python-setuptools' 'python-apt' 'python2-apt')
+options=(!emptydirs)
+source=("https://mirrors.ocf.berkeley.edu/debian/pool/main/g/germinate/${_pkgname}_$pkgver.tar.xz")
+sha256sums=('aeadbd250ef4c065cc9aa0b0a7410ddee49b5c4aa31209c4f66d23652da612eb')
+
+# Base
+# Build last
+package_germinate() {
+ cd "${_pkgname}"
+ depends+=('perl' 'python')
+
+ # Initial python build
+ python setup.py build
+
+ # Install files to /usr/bin
+ mkdir -p $pkgdir/usr/bin || return 1
+ cp bin/germinate $pkgdir/usr/bin/. || return 1
+ cp bin/germinate-pkg-diff $pkgdir/usr/bin/. || return 1
+ cp bin/germinate-update-metapackage $pkgdir/usr/bin/. || return 1
+ cp debhelper/dh_germinate_clean $pkgdir/usr/bin/. || return 1
+ cp debhelper/dh_germinate_metapackage $pkgdir/usr/bin/. || return 1
+
+ # Install perl libs
+ mkdir -p $pkgdir/usr/share/perl5/vendor_perl/Debhelper/Sequence || return 1
+ cp debhelper/germinate.pm $pkgdir/usr/share/perl5/vendor_perl/Debhelper/Sequence/. || return 1
+
+ # Install man pages (keep original files, or python builds will fail)
+ mkdir -p $pkgdir/usr/share/man/man1 || return 1
+ gzip -k debhelper/*.1 || return 1
+ cp debhelper/dh_germinate_clean.1.gz $pkgdir/usr/share/man/man1/. || return 1
+ cp debhelper/dh_germinate_metapackage.1.gz $pkgdir/usr/share/man/man1/. || return 1
+ gzip -k man/*.1 || return 1
+ cp man/germinate-pkg-diff.1.gz $pkgdir/usr/share/man/man1/. || return 1
+ cp man/germinate-update-metapackage.1.gz $pkgdir/usr/share/man/man1/. || return 1
+ cp man/germinate.1.gz $pkgdir/usr/share/man/man1/. || return 1
+}
+
+# Python libs
+# Build this first
+package_python-germinate() {
+ cd "${_pkgname}"
+ depends+=('germinate' 'python')
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ # Remove already installed portions
+ rm -rf $pkgdir/usr/share/man
+ rm -rf $pkgdir/usr/share/perl5
+ rm -rf $pkgdir/usr/bin
+}
+
+# Python2 libs
+package_python2-germinate() {
+ cd "${_pkgname}"
+ depends+=('germinate' 'python2')
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ # Remove already installed portions
+ rm -rf $pkgdir/usr/share/man
+ rm -rf $pkgdir/usr/share/perl5
+ rm -rf $pkgdir/usr/bin
+}
+