summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-01-28 10:05:53 -0600
committerLuis Martinez2022-01-28 10:05:53 -0600
commitfe41cb15f7302d2cca172a10904e948af31475d0 (patch)
tree8f229d8b9c98bb97023d321e627565e169798036
parent63e780ff9fe5308a4f358e97550f0fff81acccff (diff)
downloadaur-fe41cb15f7302d2cca172a10904e948af31475d0.tar.gz
update to 2.38
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD71
2 files changed, 29 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fbb6c296a62..04e3d66b52e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,19 @@
pkgbase = germinate
pkgdesc = Expands dependencies in a list of seed packages
- pkgver = 2.37
- pkgrel = 2
+ pkgver = 2.38
+ pkgrel = 1
url = https://tracker.debian.org/pkg/germinate
- arch = x86_64
+ arch = any
license = GPL
makedepends = python-setuptools
makedepends = python-apt
- makedepends = python2-apt
- makedepends = python2-setuptools
- options = !emptydirs
- source = https://mirrors.ocf.berkeley.edu/debian/pool/main/g/germinate/germinate_2.37.tar.xz
- sha256sums = 367771cdd892cfa94a46b8df8afec1060604b93d7bb98170d406bcdaddbfd096
+ source = germinate-2.38.tar.xz::https://deb.debian.org/debian/pool/main/g/germinate/germinate_2.38.tar.xz
+ sha256sums = e998ba09fb90fddc6816b37931377906e013ef0b80a47766aba651e43180e800
pkgname = germinate
depends = perl
- depends = python
pkgname = python-germinate
depends = germinate
- depends = python
depends = python-apt
-
-pkgname = python2-germinate
- depends = germinate
- depends = python2
- depends = python2-apt
+ depends = python-six
diff --git a/PKGBUILD b/PKGBUILD
index 8509f6bb68f2..d248ade00892 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,41 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Jacob Alexander <haata at kiibohd com>
-pkgbase=germinate
-pkgname=('germinate' 'python-germinate' 'python2-germinate')
-_pkgname=${pkgname[0]}
-pkgver=2.37
-pkgrel=2
+pkgname=('germinate' 'python-germinate')
+pkgver=2.38
+pkgrel=1
pkgdesc='Expands dependencies in a list of seed packages'
-arch=('x86_64')
+arch=('any')
url="https://tracker.debian.org/pkg/germinate"
license=('GPL')
-makedepends=('python-setuptools' 'python-apt' 'python2-apt' 'python2-setuptools')
-options=(!emptydirs)
-source=("https://mirrors.ocf.berkeley.edu/debian/pool/main/g/germinate/${_pkgname}_$pkgver.tar.xz")
-sha256sums=('367771cdd892cfa94a46b8df8afec1060604b93d7bb98170d406bcdaddbfd096')
+makedepends=('python-setuptools' 'python-apt')
+source=("$pkgname-$pkgver.tar.xz::https://deb.debian.org/debian/pool/main/g/$pkgname/${pkgname}_$pkgver.tar.xz")
+sha256sums=('e998ba09fb90fddc6816b37931377906e013ef0b80a47766aba651e43180e800')
-# Base
-# Build last
-package_germinate() {
+prepare() {
cd work
- depends+=('perl' 'python')
+ sed -i \
+ -e '/packages=/c\packages=find_packages(exclude=["*tests*"]),' \
+ setup.py
+}
- # Initial python build
+build() {
+ cd work
python setup.py build
+}
- # Install files to /usr/bin
- install -Dm 755 bin/germinate{,-pkg-diff,-update-metapackage} -t "$pkgdir/usr/bin"
-
- # Install perl libs
- install -Dm 644 debhelper/germinate.pm -t "$pkgdir/usr/share/perl5/vendor_perl/Debhelper/Sequence/"
+package_germinate() {
+ depends=('perl')
- # Install man pages (keep original files, or python builds will fail)
- install -Dm 644 \
- debhelper/dh_germinate_{clean,metapackage} \
- man/germinate{,-pkg-diff,-update-metapackage}.1 \
- -t "$pkgdir/usr/share/man/man1/"
+ cd work
+ install -Dm644 debhelper/germinate.pm -t "$pkgdir/usr/share/perl5/vendor_perl/Debhelper/Sequence/"
}
-# Python libs
-# Build this first
package_python-germinate() {
- cd work
- depends+=('germinate' 'python' 'python-apt')
-
- python setup.py install --root="$pkgdir/" --optimize=1
-
- # Remove already installed portions
- rm -rf $pkgdir/usr/share/man
- rm -rf $pkgdir/usr/share/perl5
- rm -rf $pkgdir/usr/bin
-}
+ depends+=('germinate' 'python-apt' 'python-six')
-# Python2 libs
-package_python2-germinate() {
+ export PYTHONHASHSEED=0
cd work
- depends+=('germinate' 'python2' 'python2-apt')
-
- python2 setup.py install --root="$pkgdir/" --optimize=1
-
- # Remove already installed portions
- rm -rf $pkgdir/usr/share/man
- rm -rf $pkgdir/usr/share/perl5
- rm -rf $pkgdir/usr/bin
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}