summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Merry2020-06-28 23:14:36 +0100
committerAlex Merry2020-06-28 23:14:36 +0100
commit291de7fb01eb10f5657b35dd398b4bc27f9a2df8 (patch)
treec1d83026ba6220c12f1bcc5434901d22ced50422
parent74b555c3abf80e127b14e89ff6169c5537e37c89 (diff)
downloadaur-291de7fb01eb10f5657b35dd398b4bc27f9a2df8.tar.gz
Update to 3.26, and make mojolicious required
In practice, get_iplayer is pretty useless without perl-mojolicious as it will not update the index.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d1bea8b0434..41b672b97cfd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Sun May 24 17:45:39 UTC 2020
pkgbase = get_iplayer
pkgdesc = Allows you to download or stream any iPlayer programme from the BBC in H.264 (Quicktime/mp4) format, any radio programmes in MP3 or RealAudio format
- pkgver = 3.25
- pkgrel = 2
- url = http://www.infradead.org/get_iplayer/html/get_iplayer.html
+ pkgver = 3.26
+ pkgrel = 1
+ url = https://github.com/get-iplayer/get_iplayer/
install = get_iplayer.install
arch = any
license = GPL3
@@ -13,12 +11,12 @@ pkgbase = get_iplayer
depends = perl-lwp-protocol-https
depends = perl-libwww
depends = perl-xml-libxml
+ depends = perl-mojolicious
optdepends = atomicparsley: add tags to MP4 files
optdepends = ffmpeg: convert flash (flv) files
optdepends = perl-cgi: web PVR manager
- optdepends = perl-mojolicious: significantly faster indexing (highly recommended)
- source = https://github.com/get-iplayer/get_iplayer/archive/v3.25.tar.gz
- md5sums = 6c9a2b1b138ffc5b69ee4ecaa76d62d1
+ source = https://github.com/get-iplayer/get_iplayer/archive/v3.26.tar.gz
+ md5sums = 425901e2ff6742386eeb9f8aa3661b30
pkgname = get_iplayer
diff --git a/PKGBUILD b/PKGBUILD
index eb5ed962395f..062db7430e0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Alex Merry <dev@randomguy3.me.uk>
pkgname=get_iplayer
-pkgver=3.25
-pkgrel=2
+pkgver=3.26
+pkgrel=1
pkgdesc="Allows you to download or stream any iPlayer programme from the BBC in H.264 (Quicktime/mp4) format, any radio programmes in MP3 or RealAudio format"
arch=('any')
-url="http://www.infradead.org/get_iplayer/html/get_iplayer.html"
+url="https://github.com/get-iplayer/get_iplayer/"
license=('GPL3')
depends=(
'perl>=5.10.1'
'perl-json-pp' # part of perl from 5.14 onwards
'perl-lwp-protocol-https' # Basic access to servers
'perl-libwww' # Basic access to servers
- 'perl-xml-libxml') # Page scraping and subtitles
+ 'perl-xml-libxml' # Page scraping and subtitles
+ 'perl-mojolicious') # Fetching indexes
optdepends=(
'atomicparsley: add tags to MP4 files'
'ffmpeg: convert flash (flv) files'
- 'perl-cgi: web PVR manager'
- 'perl-mojolicious: significantly faster indexing (highly recommended)')
+ 'perl-cgi: web PVR manager')
install=get_iplayer.install
source=(https://github.com/get-iplayer/get_iplayer/archive/v${pkgver}.tar.gz)
-md5sums=('6c9a2b1b138ffc5b69ee4ecaa76d62d1')
+md5sums=('425901e2ff6742386eeb9f8aa3661b30')
package() {
cd "$srcdir/$pkgname-$pkgver"