summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122016-07-04 08:49:29 +0200
committerwillemw122016-07-04 08:51:08 +0200
commit8e7846e7ef1dcc063495b688700cef65905e043e (patch)
tree629c65ed1484f1071f655fad9564c0b78f676ad4
parent7c13b5987df5119bf2afb886ee9fc3af47347c87 (diff)
downloadaur-8e7846e7ef1dcc063495b688700cef65905e043e.tar.gz
Add 'perl-libwww' dep. Remove 'perl-http-cookies', 'perl-net-http', 'perl-www-mechanize' deps.
Group deprecated deps. Remove deprecated program deps. Remove plugins installation. Update title.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 22 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 439e85b54470..cbd51cc7e0b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,27 @@
pkgbase = get_iplayer-git
- pkgdesc = Download TV and radio from BBC iPlayer
- pkgver = 2.94.r2.g52a2c12
- pkgrel = 2
+ pkgdesc = Download TV and radio programmes from BBC iPlayer
+ pkgver = 2.95
+ pkgrel = 1
url = https://github.com/get-iplayer/get_iplayer
arch = any
license = GPL3
makedepends = git
- depends = perl-html-parser
- depends = perl-http-cookies
depends = perl-libwww
- depends = perl-net-http
- depends = perl-www-mechanize
+ depends = perl-xml-libxml
depends = perl-xml-simple
+ depends = perl-html-parser
optdepends = atomicparsley: MP4 and M4A files metadata tagging
optdepends = atomicparsley-largefile-hg: MP4 and M4A files metadata tagging (preferred)
optdepends = ffmpeg: FLV files to MP4, M4A, MP3 or AVI files
- optdepends = flvstreamer: Flash audio/video streams to FLV files. An "rtmpdump" alternative
- optdepends = id3v2: MP3 files metadata tagging. Alternative "perl-mp3-tag" is preferred (full ID3 tagging)
- optdepends = lame: MP3 encoder
- optdepends = mplayer: FLV files to MP3 files. Windows Media audio streams to WMA files
optdepends = perl-authen-sasl: Mail search results via SSL
optdepends = perl-mp3-info: Catalogue MP3 files in localfiles plugin
optdepends = perl-mp3-tag: MP3 files metadata tagging
optdepends = perl-net-smtp-ssl: Mail search results via SSL
optdepends = perl-net-smtp-tls: Mail search results via TLS
+ optdepends = perl-net-smtps: Mail search results via TLS (alternative)
+ optdepends = flvstreamer: Flash audio/video streams to FLV files. An "rtmpdump" alternative
+ optdepends = id3v2: MP3 files metadata tagging. Alternative "perl-mp3-tag" is preferred (full ID3 tagging)
optdepends = rtmpdump: Flash audio/video streams to FLV files
- optdepends = vlc: 3gp / N95 h.264 streams
provides = get_iplayer
conflicts = get_iplayer
source = get_iplayer-git::git://github.com/get-iplayer/get_iplayer.git
diff --git a/PKGBUILD b/PKGBUILD
index 3b91f61c607d..d8a170aff61f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,38 +6,37 @@
_pkgname=get_iplayer
pkgname=$_pkgname-git
-pkgver=2.94.r2.g52a2c12
-pkgrel=2
-pkgdesc="Download TV and radio from BBC iPlayer"
+pkgver=2.95
+pkgrel=1
+pkgdesc="Download TV and radio programmes from BBC iPlayer"
arch=('any')
url="https://github.com/get-iplayer/get_iplayer"
license=('GPL3')
# perl-libwww is the LWP module
-# 'perl-json: metadata parsing'
-depends=('perl-html-parser' 'perl-http-cookies' 'perl-libwww' 'perl-net-http' 'perl-www-mechanize' 'perl-xml-simple')
+depends=('perl-libwww'
+ 'perl-xml-libxml'
+ 'perl-xml-simple'
+
+ 'perl-html-parser')
-# 'perl-net-smtps: Mail search results via TLS (alternative)'
optdepends=(
- #'atomicparsley: MP4 and M4A files metadata tagging. Newer "atomicparsley-largefile-hg" is preferred'
- #
# Having only 'optdepends atomicparsley' is sufficient to install either atomicparsley or atomicparsley-largefile-hg.
# However, added 'optdepends atomicparsley-largefile-hg' so 'pacman -Qi' will show 'atomicparsley-largefile-hg [installed]'
'atomicparsley: MP4 and M4A files metadata tagging'
'atomicparsley-largefile-hg: MP4 and M4A files metadata tagging (preferred)'
-
'ffmpeg: FLV files to MP4, M4A, MP3 or AVI files'
- 'flvstreamer: Flash audio/video streams to FLV files. An "rtmpdump" alternative'
- 'id3v2: MP3 files metadata tagging. Alternative "perl-mp3-tag" is preferred (full ID3 tagging)'
- 'lame: MP3 encoder'
- 'mplayer: FLV files to MP3 files. Windows Media audio streams to WMA files'
+
+ # Deprecated
'perl-authen-sasl: Mail search results via SSL'
'perl-mp3-info: Catalogue MP3 files in localfiles plugin'
'perl-mp3-tag: MP3 files metadata tagging'
'perl-net-smtp-ssl: Mail search results via SSL'
'perl-net-smtp-tls: Mail search results via TLS'
- 'rtmpdump: Flash audio/video streams to FLV files'
- 'vlc: 3gp / N95 h.264 streams')
+ 'perl-net-smtps: Mail search results via TLS (alternative)'
+ 'flvstreamer: Flash audio/video streams to FLV files. An "rtmpdump" alternative'
+ 'id3v2: MP3 files metadata tagging. Alternative "perl-mp3-tag" is preferred (full ID3 tagging)'
+ 'rtmpdump: Flash audio/video streams to FLV files')
makedepends=('git')
conflicts=($_pkgname)
@@ -60,8 +59,5 @@ package() {
install -Dm644 README.md "$pkgdir/usr/share/doc/get_iplayer/README.md"
install -Dm644 get_iplayer.1 "$pkgdir/usr/share/man/man1/get_iplayer.1"
-
- install -dm755 "$pkgdir/usr/share/get_iplayer/plugins"
- install -m644 plugins/*.plugin plugins/plugin.template "$pkgdir/usr/share/get_iplayer/plugins/"
}