summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2017-07-25 11:48:25 +0200
committer5chdn2017-07-25 11:48:25 +0200
commit1209322b51e5c099b8dfde1e21ed9a9790ee075c (patch)
tree3dee6752d020787c4ec3bd5f4b846255c97116cc
parent861b40031ce46a33d804cf2db9d89662ef333a36 (diff)
downloadaur-1209322b51e5c099b8dfde1e21ed9a9790ee075c.tar.gz
Version bump and fix binaries
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
2 files changed, 31 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d92c591954ae..2a04e0207432 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Dec 23 10:17:35 UTC 2016
+# Tue Jul 25 09:48:10 UTC 2017
pkgbase = geth-git
pkgdesc = Ethereum Go Client
- pkgver = 1.5.5.r31.g115364b0a
+ pkgver = 1.6.7.r24.g3a678a15c
pkgrel = 1
url = https://github.com/ethereum/go-ethereum
arch = i686
@@ -12,7 +12,14 @@ pkgbase = geth-git
makedepends = go
makedepends = gmp
depends = glibc
+ optdepends = mist: Mist dapp browser and Ethereum wallet.
provides = geth
+ provides = abigen
+ provides = bootnode
+ provides = disasm
+ provides = evm
+ provides = gethrpctest
+ provides = rlpdump
conflicts = geth-git
conflicts = go-ethereum
conflicts = go-ethereum-git
diff --git a/PKGBUILD b/PKGBUILD
index 4746275446c6..7dd8af335aea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: David Parrish <daveparrish@tutanota.com>
-# Co-Maintainer: Afri 5chdn <aur@cach.co>
+# Maintainer: Afri 5chdn <aur@5chdn.co>
+# Contributor: David Parrish <daveparrish@tutanota.com>
pkgname=geth-git
-pkgver=1.5.5.r31.g115364b0a
+pkgver=1.6.7.r24.g3a678a15c
pkgrel=1
pkgdesc="Ethereum Go Client"
arch=('i686' 'x86_64')
@@ -15,7 +15,18 @@ conflicts=(
'go-ethereum'
'go-ethereum-git'
)
-provides=('geth')
+optdepends=(
+ 'mist: Mist dapp browser and Ethereum wallet.'
+)
+provides=(
+ 'geth'
+ 'abigen'
+ 'bootnode'
+ 'disasm'
+ 'evm'
+ 'gethrpctest'
+ 'rlpdump'
+)
source=("${pkgname}::git+https://github.com/ethereum/go-ethereum.git#branch=master")
sha256sums=('SKIP')
@@ -26,11 +37,17 @@ pkgver() {
build() {
cd "${srcdir}/${pkgbase}"
- make
+ make all
}
package() {
cd "$pkgbase"
install -Dm755 build/bin/geth "$pkgdir"/usr/bin/geth
+ install -Dm755 build/bin/geth "$pkgdir"/usr/bin/abigen
+ install -Dm755 build/bin/geth "$pkgdir"/usr/bin/bootnode
+ install -Dm755 build/bin/geth "$pkgdir"/usr/bin/disasm
+ install -Dm755 build/bin/geth "$pkgdir"/usr/bin/evm
+ install -Dm755 build/bin/geth "$pkgdir"/usr/bin/gethrpctest
+ install -Dm755 build/bin/geth "$pkgdir"/usr/bin/rlpdump
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}