summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2016-03-03 20:40:30 +0100
committer5chdn2016-03-03 20:40:30 +0100
commit25e07bfdeac07b25c250826043c1ee62faed24d6 (patch)
tree2fbe7c97fdb9497483e2865c2a33ffbe8767a710
parentffe63b074ecba80f33d5eb2913de5846a87a05c2 (diff)
downloadaur-25e07bfdeac07b25c250826043c1ee62faed24d6.tar.gz
Homestead hotfix release 1.3.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b56713ce7e1b..21c29f21d9c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jan 20 16:20:57 UTC 2016
+# Thu Mar 3 19:39:57 UTC 2016
pkgbase = geth-git
pkgdesc = Ethereum Go Client
- pkgver = v0.9.39.r563.ge7f6798
+ pkgver = v0.9.39.r714.gd45f01d
pkgrel = 1
url = https://github.com/ethereum/go-ethereum
arch = i686
@@ -11,7 +11,11 @@ pkgbase = geth-git
license = GPL3
makedepends = go
makedepends = gmp
+ optdepends = mist: Graphical Ethereum wallet and DApps browser.
provides = geth
+ conflicts = geth-git
+ conflicts = go-ethereum
+ conflicts = go-ethereum-git
source = geth-git::git+https://github.com/ethereum/go-ethereum.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 44efdf9a7bb1..6922fd7c3baf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,34 @@
# Maintainer: David Parrish <daveparrish@gmail.com>
pkgname=geth-git
-pkgver=v0.9.39.r563.ge7f6798
+pkgver=v0.9.39.r714.gd45f01d
pkgrel=1
pkgdesc="Ethereum Go Client"
arch=('i686' 'x86_64')
url="https://github.com/ethereum/go-ethereum"
license=('LGPL3' 'GPL3')
makedepends=('go' 'gmp')
+optdepends=('mist: Graphical Ethereum wallet and DApps browser.')
+conflicts=(
+ 'geth-git'
+ 'go-ethereum'
+ 'go-ethereum-git'
+)
provides=('geth')
source=("${pkgname}::git+https://github.com/ethereum/go-ethereum.git")
sha256sums=('SKIP')
pkgver() {
cd "$pkgbase"
+ git checkout -q develop
+ git pull -q
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${srcdir}/${pkgbase}"
+ git checkout develop
+ git pull
make
}