summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Aaron Goldberg2020-09-02 13:47:22 -0400
committerBen Aaron Goldberg2020-09-02 13:47:22 -0400
commit12e709335efaa636ad67a3c68f3308ca258a3aab (patch)
tree54c3e7d5dc5e1fa6ed8da88e43056f2f69c23957
downloadaur-12e709335efaa636ad67a3c68f3308ca258a3aab.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9edcce6b978c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = geticons
+ pkgdesc = CLI tool to get icons on Linux and other Freedesktop systems
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://git.sr.ht/~zethra/geticons
+ arch = x86_64
+ license = GPL
+ makedepends = cargo
+ depends = bash
+ depends = icons-in-terminal
+ source = https://git.sr.ht/~zethra/geticons/archive/0.1.0.tar.gz
+ sha256sums = 3cd90163a7f7e3588ba87bd50ef1ddaad14e583d4a5a656ef02fc414d9933239
+
+pkgname = geticons
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d66563c51a44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ben Golberg <ben@benaaron.dev>
+
+pkgname=geticons
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="CLI tool to get icons on Linux and other Freedesktop systems"
+arch=('x86_64')
+makedepends=('cargo')
+depends=('bash' 'icons-in-terminal')
+url="https://git.sr.ht/~zethra/geticons"
+license=('GPL')
+source=("https://git.sr.ht/~zethra/geticons/archive/${pkgver}.tar.gz")
+sha256sums=('3cd90163a7f7e3588ba87bd50ef1ddaad14e583d4a5a656ef02fc414d9933239')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm755 geticons "${pkgdir}/usr/bin/geticons"
+ install -Dm644 geticons.1 "$pkgdir/usr/share/man/man1/geticons.1"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/geticons/" LICENSE
+}