summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormahdymirzade2021-07-28 23:16:10 +0430
committermahdymirzade2021-07-28 23:16:10 +0430
commitab76f59a93e153294fc6ccd69a7868b9432b952e (patch)
treefc96c3b16b1413053804c0929e2d91a81789eb90
downloadaur-ab76f59a93e153294fc6ccd69a7868b9432b952e.tar.gz
Update
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67972bc6d04f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gip
+ pkgdesc = Get Private/Public IP & IP's Geolocation.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/mahdymirzade/gip
+ arch = any
+ license = GPL-3.0
+ makedepends = git
+ depends = bind
+ depends = grep
+ depends = curl
+ source = https://github.com/MahdyMirzade/gip/archive/refs/tags/1.0.1.tar.gz
+ sha256sums = 1dfa5c62252b70c2f14319479a59163d1e3270b0d459a30ed42efbeab44d9d53
+
+pkgname = gip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58cae0bdef7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Mahdy Mirzade <me@mahdym.ir>
+pkgname=gip
+pkgver=1.0
+pkgrel=1
+pkgdesc="Get Private/Public IP & IP's Geolocation."
+arch=(any)
+url="https://github.com/mahdymirzade/gip"
+license=('GPL-3.0')
+depends=('bind' 'grep' 'curl')
+makedepends=('git')
+source=("https://github.com/MahdyMirzade/$pkgname/archive/refs/tags/$pkgver.$pkgrel.tar.gz")
+sha256sums=("1dfa5c62252b70c2f14319479a59163d1e3270b0d459a30ed42efbeab44d9d53")
+
+package() {
+ path="$srcdir/$pkgname-$pkgver.$pkgrel"
+ cd $path
+ install -Dm755 "$path/$pkgname" "${pkgdir}/usr/bin/$pkgname"
+}