summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-10-31 00:01:09 +0200
committerKr1ss2021-10-31 00:01:09 +0200
commita7b0641b6c5a9153d6aecef4971e38f7d2eff543 (patch)
tree80c72bb641b8622295c271448d30559a2b2f45ee
parent488f94baab7575ea57e1679f01f0efbb6bbf6d89 (diff)
downloadaur-a7b0641b6c5a9153d6aecef4971e38f7d2eff543.tar.gz
update: getmail6-git 1:6.18.5.r0.3b8bc16-1
upstream release; update changelog
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGELOG6
-rw-r--r--PKGBUILD8
3 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6b09371166c..8b233e32c077 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = getmail6-git
pkgdesc = POP3 mail retriever with reliable Maildir and command delivery; Python 3 port
- pkgver = 6.18.4.r2.1febf7c
+ pkgver = 6.18.5.r0.3b8bc16
pkgrel = 1
epoch = 1
url = https://getmail6.org
@@ -12,7 +12,7 @@ pkgbase = getmail6-git
depends = python-chardet
optdepends = python-keyring: secure password store
optdepends = python-keyrings-alt: alternative backends
- provides = getmail=6.18.4.r2.1febf7c
+ provides = getmail=6.18.5.r0.3b8bc16
provides = getmail6
conflicts = getmail
source = git+https://github.com/getmail6/getmail6.git
diff --git a/CHANGELOG b/CHANGELOG
index d9ddd5ace776..b4987357fb65 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,9 @@
+Version 6.18.5
+30 October 2021
+ - #93: IMAP: Deal better with untagged status updates
+ - #95: UnicodeDecodeError: 'utf-8' codec can't decode byte 0xa9 in position 0: invalid start byte
+ - #96: getmail_fetch: TypeError: method expected 2 arguments, got 3
+
Version 6.18.4
26 September 2021
- #91: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 11: ordinal not in range(128)
diff --git a/PKGBUILD b/PKGBUILD
index 16e13cb71dad..7dd8b3cd80aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _name="${pkgname%-git}"
epoch=1
pkgver() { git -C "$_name" describe --long | sed 's/^v//;s/-/.r/;s/-g/./'; }
-pkgver=6.18.4.r2.1febf7c
+pkgver=6.18.5.r0.3b8bc16
pkgrel=1
pkgdesc='POP3 mail retriever with reliable Maildir and command delivery; Python 3 port'
@@ -14,7 +14,7 @@ arch=('any')
url="https://$_name.org"
license=('GPL2')
-provides=("getmail=$pkgver" "${pkgname%-git}")
+provides=("getmail=$pkgver" "$_name")
conflicts=('getmail')
makedepends=('git' 'python-setuptools')
@@ -29,12 +29,12 @@ b2sums=('SKIP')
build() {
cd "$_name"
- python setup.py build
+ PYTHONHASHSEED=0 python setup.py build
}
package() {
cd "$_name"
- PYTHONHASHSEED=0 python setup.py install --skip-build --optimize=1 --root="$pkgdir"
+ python setup.py install --skip-build --optimize=1 --root="$pkgdir"
}