summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-07-06 17:30:29 +0200
committerKr1ss2021-07-06 17:30:29 +0200
commitaa27d75af6ee50f793c1da0299b0d0bad66ae546 (patch)
tree1d8b922a28ed14eb631a3d0f3abdf113912252bd
parentde00b3d981042c4ba4ccb2d428f9dfc86982ec68 (diff)
downloadaur-aa27d75af6ee50f793c1da0299b0d0bad66ae546.tar.gz
update: getmail6-git 1:6.18.r1.9d15886-1
upstream release; update changelog
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGELOG8
-rw-r--r--PKGBUILD21
3 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fad6b40f1eb..6ae3744937f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = getmail6-git
pkgdesc = POP3 mail retriever with reliable Maildir and command delivery; Python 3 port
- pkgver = 6.17.r504.78375eb
+ pkgver = 6.18.r1.9d15886
pkgrel = 1
epoch = 1
url = https://getmail6.org
@@ -12,7 +12,7 @@ pkgbase = getmail6-git
depends = python-chardet
optdepends = python-keyring: secure password store
optdepends = python-keyrings-alt: alternative backends
- provides = getmail=6.17.r504.78375eb
+ provides = getmail=6.18.r1.9d15886
provides = getmail6
conflicts = getmail
source = git+https://github.com/getmail6/getmail6.git
diff --git a/CHANGELOG b/CHANGELOG
index 8f30fa3d820a..62c390ff3b1e 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,11 @@
+Version 6.18
+06 July 2021
+ - #89: fetchmail feature: skip fetching read mail.
+ New `imap_search` and `imap_on_delete` to fetch only `Unseen` messages and set them to `\Seen`.
+ - add `-s/--searchset` to override imap search and setting of flags for all rcfile's in the command
+ - if no `--rcfile` and no default `getmailrc`, then use all files from the `--getmaildir` folder
+ - fix "SyntaxError: Non-ASCII in file, but no encoding declared" (only Python 2.7)
+
Version 6.17
15 June 2021
- #79: UnicodeEncodeError: 'ascii' codec can't encode character in position
diff --git a/PKGBUILD b/PKGBUILD
index 808e0da7440f..354198dd4a96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,16 @@
pkgname=getmail6-git
-_pkgname="${pkgname%-git}"
+_name="${pkgname%-git}"
epoch=1
-pkgver() {
- cd "$_pkgname"
- printf '%s.r%s.%s' \
- "$(git tag -l | sed -r 's/v?([0-9\.]+)(-.+)?/\1/g' | sort -Vr | sed 1q)" \
- "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-pkgver=6.17.r504.78375eb
+pkgver() { git -C "$_name" describe --long | sed 's/^v//;s/-/.r/;s/-g/./'; }
+pkgver=6.18.r1.9d15886
pkgrel=1
pkgdesc='POP3 mail retriever with reliable Maildir and command delivery; Python 3 port'
arch=('any')
-url="https://$_pkgname.org"
+url="https://$_name.org"
license=('GPL2')
provides=("getmail=$pkgver" "${pkgname%-git}")
@@ -28,18 +23,18 @@ optdepends=('python-keyring: secure password store'
'python-keyrings-alt: alternative backends')
changelog=CHANGELOG
-source=("git+https://github.com/$_pkgname/$_pkgname.git")
+source=("git+https://github.com/$_name/$_name.git")
b2sums=('SKIP')
build() {
- cd "$_pkgname"
+ cd "$_name"
python setup.py build
}
package() {
- cd "$_pkgname"
- python setup.py install --skip-build --optimize=1 --root="$pkgdir"
+ cd "$_name"
+ PYTHONHASHSEED=0 python setup.py install --skip-build --optimize=1 --root="$pkgdir"
}