summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2020-11-02 00:22:07 +0100
committerKr1ss2020-11-02 00:22:07 +0100
commitf34beb167842236f915f2d08b08c9499e662114d (patch)
treeca402647544c362dce5c0b8295f2e86bce432db0
parent8427bc8b135da5f263674b8667bd018f88017f71 (diff)
downloadaur-f34beb167842236f915f2d08b08c9499e662114d.tar.gz
add optional keyring library dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG6
-rw-r--r--PKGBUILD4
3 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b90af3a870f2..daef4d619e7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = getmail6-git
pkgdesc = POP3 mail retriever with reliable Maildir and command delivery; Python 3 port
- pkgver = 6.8.r0.beec49a
+ pkgver = 6.8.r7.c99d1ea
pkgrel = 1
epoch = 1
url = http://getmail6.org
@@ -9,7 +9,9 @@ pkgbase = getmail6-git
license = GPL2
makedepends = git
depends = python-chardet
- provides = getmail=6.8.r0.beec49a
+ optdepends = python-keyring: secure password store
+ optdepends = python-keyrings-alt: alternative backends
+ provides = getmail=6.8.r7.c99d1ea
provides = getmail6
conflicts = getmail
source = git+https://github.com/getmail6/getmail6.git
diff --git a/CHANGELOG b/CHANGELOG
index aa394fdf0857..115832676874 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,9 @@
+Version 6.9
+TODO
+ - fix python 3.9 issues #42 #44
+ - fix regex warning #45
+ - add usage of Python keyring package in addition to gnomekeyring (#43)
+
Version 6.8
07 October 2020
- fix #37: update copyright date and notices
diff --git a/PKGBUILD b/PKGBUILD
index eaef361d0f6d..16828eba45c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgname="${pkgname%-git}"
epoch=1
pkgver() { git -C "$_pkgname" describe --tags --long | sed 's/^v//;s/-/.r/;s/-g/./'; }
-pkgver=6.8.r0.beec49a
+pkgver=6.8.r7.c99d1ea
pkgrel=1
pkgdesc='POP3 mail retriever with reliable Maildir and command delivery; Python 3 port'
@@ -19,6 +19,8 @@ conflicts=('getmail')
makedepends=('git')
depends=('python-chardet')
+optdepends=('python-keyring: secure password store'
+ 'python-keyrings-alt: alternative backends')
changelog=CHANGELOG
source=("git+https://github.com/$_pkgname/$_pkgname.git")