summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2018-05-03 16:32:05 +0200
committerJulian Xhokaxhiu2018-05-03 16:32:05 +0200
commit8ba15116a9381f8767216da4430c1f5265e9050a (patch)
tree8a405166a7933ee37405763f632537bab280bd81
downloadaur-8ba15116a9381f8767216da4430c1f5265e9050a.tar.gz
First commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD17
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..951e0cc66b01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = getmu
+ pkgdesc = A full-stack DevOps on AWS framework
+ pkgver = 1.4.5
+ pkgrel = 1
+ url = https://github.com/stelligent/mu
+ arch = x86_64
+ license = MIT
+ source = https://github.com/stelligent/mu/releases/download/v1.4.5/mu-linux-amd64
+ md5sums = 00b32123eb52a514e52de25532110b23
+
+pkgname = getmu
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31b3675bb091
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# ...but
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e8218e2c4ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+#Maintainer: Julian Xhokaxhiu <info at julianxhokaxhiu dot com>
+
+pkgname=getmu
+pkgver=1.4.5
+pkgrel=1
+pkgdesc="A full-stack DevOps on AWS framework"
+arch=('x86_64')
+source=("https://github.com/stelligent/mu/releases/download/v$pkgver/mu-linux-amd64")
+url="https://github.com/stelligent/mu"
+license=("MIT")
+md5sums=("00b32123eb52a514e52de25532110b23")
+
+package() {
+ cd "$srcdir"
+ chmod +x "mu-linux-amd64"
+ install -Dm755 "mu-linux-amd64" "$pkgdir/usr/bin/mu"
+}