summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Woodbine2018-06-26 21:46:46 +1200
committerCaleb Woodbine2018-06-26 21:46:46 +1200
commite875aebbf5598d336d51272da6e5200ace96b452 (patch)
treec24bbb572b7b16b5f46dd2bc4f903431c00c31aa
parent8c17b987d4d1a373f255cd07abbd0cda43d08368 (diff)
downloadaur-e875aebbf5598d336d51272da6e5200ace96b452.tar.gz
Updated package to version 2.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10e8feab491b..604807aefcf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = getnewip
pkgdesc = Sync dynamic public IP addresses of GNU/Linux servers with the hostname in a user's SSH config file, via Dropbox.
- pkgver = 2.1.2
+ pkgver = 2.2
pkgrel = 1
url = https://gitlab.com/BobyMCbobs/getnewip
arch = any
@@ -9,8 +9,8 @@ pkgbase = getnewip
depends = curl
depends = bash
depends = openssh
- source = https://gitlab.com/BobyMCbobs/getnewip/-/archive/2.1.2/getnewip-2.1.2.zip
- md5sums = a7898ea4186adb01950c8e54227dd067
+ source = https://gitlab.com/BobyMCbobs/getnewip/-/archive/2.2/getnewip-2.2.zip
+ md5sums = c9cabadd60c799c4f2211640f95946e9
pkgname = getnewip
diff --git a/PKGBUILD b/PKGBUILD
index d63e31bdc58f..3218f0f8628a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Caleb Woodbine <gitlab.com/BobyMCbobs>
pkgname=getnewip
-pkgver=2.1.2
+pkgver=2.2
pkgrel=1
pkgdesc="Sync dynamic public IP addresses of GNU/Linux servers with the hostname in a user's SSH config file, via Dropbox."
arch=('any')
@@ -8,9 +8,19 @@ url="https://gitlab.com/BobyMCbobs/${pkgname}"
license=('GPL')
depends=('gnu-netcat' 'curl' 'bash' 'openssh')
source=("https://gitlab.com/BobyMCbobs/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.zip")
-md5sums=('a7898ea4186adb01950c8e54227dd067')
+md5sums=('c9cabadd60c799c4f2211640f95946e9')
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}
+
+pre_remove() {
+ systemctl disable getnewip
+ systemctl stop getnewip
+}
+
+post_remove() {
+ rm -rf /etc/getnewip
+
+}