summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Woodbine2018-06-08 21:36:07 +1200
committerCaleb Woodbine2018-06-08 21:36:07 +1200
commitfa1785bbd31a4a5c31700fb8c47003428beacdc5 (patch)
tree9c8d80b0c56f9043f3b2cb189d4cacc456afb687
downloadaur-fa1785bbd31a4a5c31700fb8c47003428beacdc5.tar.gz
getnewip inital commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c7a8c25727f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = getnewip
+ pkgdesc = Sync dynamic public IP addresses of GNU/Linux servers with the hostname in a user's SSH config file, via Dropbox.
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = https://gitlab.com/BobyMCbobs/getnewip
+ arch = any
+ license = GPL
+ depends = gnu-netcat
+ depends = curl
+ depends = bash
+ depends = openssh
+ source = https://gitlab.com/BobyMCbobs/getnewip/-/archive/2.1.2/getnewip-2.1.2.zip
+ md5sums = SKIP
+
+pkgname = getnewip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8554a5dbfbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Caleb Woodbine <github.com/BobyMCbobs>
+pkgname=getnewip
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="Sync dynamic public IP addresses of GNU/Linux servers with the hostname in a user's SSH config file, via Dropbox."
+arch=('any')
+url="https://gitlab.com/BobyMCbobs/${pkgname}"
+license=('GPL')
+depends=('gnu-netcat' 'curl' 'bash' 'openssh')
+source=("https://gitlab.com/BobyMCbobs/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.zip")
+md5sums=('SKIP')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}