summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstefanwimmer1282023-01-29 14:09:01 +0100
committerstefanwimmer1282023-01-29 14:09:01 +0100
commit4bfd4326df81fd43305455539ce04fcb8f519cdd (patch)
tree5465dccafa692039aaad72e1581b58014212e1ab
downloadaur-4bfd4326df81fd43305455539ce04fcb8f519cdd.tar.gz
3.3.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD23
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a56dbc5ebe5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = getoptions-bin
+ pkgdesc = An elegant option/argument parser for shell scripts
+ pkgver = 3.3.0
+ pkgrel = 1
+ url = https://github.com/ko1nksm/getoptions
+ arch = x86_64
+ license = CC0-1.0
+ provides = getoptions
+ conflicts = getoptions
+ source = getoptions-3.3.0.tar.zst::https://git.stefanwimmer128.eu/stefanwimmer128/getoptions/-/package_files/66/download
+ sha256sums = 7300dd5093855d48613849ea1e4d38b96537278152caf7191be46b902f871ac4
+
+pkgname = getoptions-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0d45b6392c73
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.zst*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61a487e8bd45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: stefanwimmer128 <info at stefanwimmer128 dot eu>
+
+_pkgname=getoptions
+pkgname=$_pkgname-bin
+pkgver=3.3.0
+pkgrel=1
+pkgdesc='An elegant option/argument parser for shell scripts'
+arch=(any)
+license=(CC0-1.0)
+url='https://github.com/ko1nksm/getoptions'
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$_pkgname-$pkgver.tar.zst::https://git.stefanwimmer128.eu/stefanwimmer128/getoptions/-/package_files/66/download")
+sha256sums=('7300dd5093855d48613849ea1e4d38b96537278152caf7191be46b902f871ac4')
+
+build() {
+ rm "$_pkgname-$pkgver.tar.zst"
+ rm .BUILDINFO .MTREE .PKGINFO
+}
+
+package() {
+ cp -r . "$pkgdir"
+}